Jump to content
AVIC411.com
VBLUE42

FINALLY: NO MORE RED DIAMOND ICON

Recommended Posts

 

I never saw a diamond on my unit with the sys.txt entry listed above.

 

As you can see here i get the diamonds but only on this screen which is okay, i'm happy with it.

 

[attachment=0]abb diamond.jpg[/attachment]

 

Since I don't ever use the 2d view, I never noticed that. Good to know. Thanks!

Share this post


Link to post
Share on other sites

 

I never saw a diamond on my unit with the sys.txt entry listed above.

 

As you can see here i get the diamonds but only on this screen which is okay, i'm happy with it.

 

[attachment=0]abb diamond.jpg[/attachment]

 

Since I don't ever use the 2d view, I never noticed that. Good to know. Thanks!

 

 

Finally had time to follow up on this more. I looked through Diaftia's mod and noticed in his data file he had 3 sub folders in his icon folder (poi, pioneer_poi & sys) All three have the multipoi.icon file.

 

VBLUE42 stated earlier that

 

If your on 3.0 the path to find the multipoi.icon has changed. Its in data.zip/ui_pioneer/icons/sys

 

This is true but i noticed that Alex had the multipoi.icon file in all 3 folders but the only one with the values changed to 79 from 74 was in the poi folder, the other two remain at 74, I followed this and added the multipoi.icon file back to the poi folder and it does indeed remove the red diamond in 2D mode

 

So you guys are both correct, I guess, but if you want the diamond gone on all screens then you will have to have the file in the poi folder. At least this is what finally fixed it for me in all modes, I no longer have any diamonds anywhere and I'm sure you can accomplish this by just the changing of the value as VBLUE42 had stated. It just seems that it has to be in the poi folder, regardless of the same file being in the other 2 folders.

 

Make any sense?

Share this post


Link to post
Share on other sites

When zipping back to DATA.zip after modifying multipoi.icon, can someone remind me which method to use?

 

1) With 7-Zip, zip to DATA.7z, then rename to DATA.zip; or

2) With 7-Zip, directly zip to DATA.zip; or

3) With WinZip or any other zip utility, directly zip to DATA.zip.

 

I always use method #2 and it works. But if I use method #1, the file size is signficantly smaller. Please note that Image.res is zipped with method 1. However, 7zip.dll is not presented in the iGo folder.

 

Thanks.

Share this post


Link to post
Share on other sites

 

1) With 7-Zip, zip to DATA.7z, then rename to DATA.zip; or

2) With 7-Zip, directly zip to DATA.zip; or

3) With WinZip or any other zip utility, directly zip to DATA.zip.

 

 

1) NOT working.

2) WORKING.

3) NOT working.

Share this post


Link to post
Share on other sites

Hello,

 

On my Avic [European F900BT upgraded in F910BT] with

[poi]
use_multi_poi_icon=0

I don't have any red diamond in 3D mode and I can see all icones. But in 2D, I already have this red diamond.

 

Do you have any suggestion to remove this diamond and show all icones (The solution to hide all icons is not good for me and I prefer to have the red diamond)

Share this post


Link to post
Share on other sites

Hi Marlysa,

 

For the 2D fix, there is a file called multipoi.icon in your ui_pioneer\icon\poi folder under the DATA.zip. All you have to do is open it, change the value of both lines from 74 to 79, and rezip it.

 

Voila!

Share this post


Link to post
Share on other sites

Hi Chuck88,

 

I already did it but this replace the diamond icon by a blank one and we don't see anymore if there is some POI or not. I don't like this solution and I prefer to have the red diamond.

 

For your information I found a solution to do it without any modification of the data.zip. [We are testing this solution with some other french AVIC users and I'll come back to explain here how to do it :wink: ]

 

My previous asking is to know if it is possible to display all icons in 2D view even if there is an overlap (Like in 3D).

Share this post


Link to post
Share on other sites
My previous asking is to know if it is possible to display all icons in 2D view even if there is an overlap (Like in 3D).

 

No.

Share this post


Link to post
Share on other sites

 

My previous asking is to know if it is possible to display all icons in 2D view even if there is an overlap (Like in 3D).

 

Hi Marlysa,

 

I afraid that I have to say no, like VBLUE42 had said. In the 2D mode there is no such thing as graphic overlay, so impossible to display one icon over another.

 

A bit off topic, since you have a forum, can you help me for this one: I have smartzoom enabled but I find that the default zoom is too far (I want the view to get closer to the car or the arrow). What is the [smartZoom] parameter that I have to adjust in order to default a closer zoom distance? This should be set in the SYS.TXT file.

 

I tried defaultzoom3d=xxx parameter but didn't work (=100 or =2000 is the same). Any idea?

 

Chuck.

Share this post


Link to post
Share on other sites

Hi Guys, don't know if anyone else has posted on this, I been away for a minute, but i just formatted my unit to get rid of junks files that had accumilated and decided to go with the FX3.1 Complete Firmware Image thread to see if it was an improvement over what I had and the first thing I noticed when I was in split screen was a kfc icon in 2d mode, never seen it before, after i got rid of red diamond there were no icons in 2d until today. Again, this might not be news but was a first for me.

 

http://avic411.com/forum/viewtopic.php?f=34&t=32351

 

on a different note, i have always used winrar for zip files because i can click on the file and a window opens to show contents without unzipping. I edit all the files in this window as well as drag and drop to overwrite, it confirms the change and then i just close the window. No unzipping and re-zipping. it is very simple and the best program i have ever used for zip files, it's on the bay, as all good things are :)

Share this post


Link to post
Share on other sites

Hello,

 

As I promised some days ago, I found a solution to suppress the red icon without any modification in data.zip. My solution is to introduce in branding.zip some specific files:

 

In folder: \ui_pioneer\icons\poi\ add this file:

 

multipoi.icon

$poi_mapdistant.bmp
$poi_mapclose.spr	79
poi_mapclose.spr	79

 

[Nota]

--------------------------------------------------------------------------------------------------------------------------

As bonus, I give you another tip to have your own icon for your personnal POI (For the example I consider my File AVICMBkml.bmp]

In folder: \ui_pioneer\icons\poi\ add this files: kmlpoi.icon

$AvicMBkml.bmp
$AvicMBkml.spr	0
AvicMBkml.spr	0

 

And place you personnal icon and its .spr file in folder: ui_pioneer\common\

For the example: AVICMBkml.bmp and AVICMBkml.spr

BmpFlags = 0
DefFlags = ALPHA_PIXEL | ALPHA_LAYER
DefPhase = 1
Stripes = 30
DefAlpha = 22

Share this post


Link to post
Share on other sites

Hey guys ive tried every which way to do this but i alway keeps getting the error when i reload into my avic. I always unzip the DATA.ZIP file make the changes to the multipoint.poi to 79 save the file, Rezip it. And then overwrite the previous DATA.ZIP file and it never works? ive tried zipping from my mac, from windows, nothing ever works? 

 

i get an program application database not found or something like that error upon boot up it says system is starting up and then it just reboots. As soon as i put the original DATA.ZIP file back startup works fine again...ive tried changing the sys.txt file too with no luck? any other ideas

 

i know i did it the write way because its not rocket science here....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×