Jump to content


Photo

2009 Scion xB Release Series 6 with Avic F900BT


  • Please log in to reply
31 replies to this topic

#1 chrisdamato

chrisdamato
  • Members
  • 7 posts

Posted 05 July 2009 - 11:10 AM

Anybody besides me get their F900BT in a new Scion xB?

It would be great to get in touch and share notes. I am nervous about making the hardware handbrake mod but I think I have identified the correct wires.

#2 jimmygunz

jimmygunz
  • Members
  • 8 posts

Posted 29 July 2009 - 02:26 PM

I have the 2008 xB release series 5.0, and i installed the F900BT when it first came out (i actually picked the unit up from the warehouse before it even hit the stores).
I am guessing the RS 6.0 has the same unit just dropped in, as i see they didnt change the dash to custom fit the F900BT. So i suggest you pop off the trim and check out the radio... do the mod, you will be much happier, especially when you want to nav on the fly. Otherwise you almost feel like your locked out.
i would like to know what they did to make the radio fully integrated into the xB... especially the speed wire, the stock ipod relocation port, the stock aux port, among other things... I have been planning on opening up my dash again to mod and make the unit 'one' with the car.... if you can i would greatly apprciate some picts and info, that is if you are diving into it....it would help limit some of the trial and error i may have to do.... please respond to the thread and/or email jimmygunz@peoplepc.com (title it 'Scion xB with AVIC-F900BT 'or something so i recognize it) i can probably help you out or let you know what i did with my install. I will take some picts and post when i get a moment... i was thinking of getting to it this weekend.

avic-f900bt
I got the trim pieces on the side from crutchfield
HD radio (now i needa get an antenna splitter if i want the MSNdirect feed)
i have the steering wheel control (it sometimes craps out though)
i ran the USB and RCAs into my glove box
I have an Alpine PLT-5 LAT sub hooked up (HIGHLY reccommend this for the xB (as it had crappy lows)- great sound and fits perfectly in the truck, with plenty of room- it looks like it is part of the car) i dont know if you can get this anymore though. my original plan was to build a custom box and power 2-12's but it would have been heavy and space consuming.
Gunz.

#3 PhatXb

PhatXb

    Member

  • Members
  • 22 posts

Posted 29 July 2009 - 09:08 PM

I don't have the FB900 or a special edition, just a standard 09 XB, but I installed the F90BT, which the wiring is basically the same. The hardwire mod is way easy. I was scared at first when I did it. And I actually did it after I installed the deck. Made it kind of a pain but it was easy anyway. Just follow the pictures seen somewhere here on the forum. I too added an amp and one 10 inch sub in a bandpass box in the back. Took up some space, but the box is actually quite small for it's design, so it doesn't hog too much trunk space, and it is loud. Amp fit great under the passenger seat. You can see pics here http://www.cardomain.com/ride/2113941. No amp pics but you can see the sub size.

#4 chrisdamato

chrisdamato
  • Members
  • 7 posts

Posted 13 August 2009 - 11:36 AM

Hey guys thanks for posting, sorry I never saw your replies sooner. Jimmygunz, I'm gonna open the dash again in the next couple days when my 3.0 chip gets here and if I can get a couple minutes I will snap and post about what's in there.

They did a good job integrating the head unit with the car, the GPS is very accurate so they must have hooked up the speed wire -- sorry I can't tell you where, they shrinkwrapped all the wiring which is why I am having such a hard time with the mod.

The ipod connection lives inside the glovebox, which on balance I prefer since my ipod mostly lives in the car.

#5 XBinRochester

XBinRochester

    Member

  • Members
  • 29 posts

Posted 13 August 2009 - 04:36 PM

I do have a RS6 with the F900BT. I did the Hardware Mod and it works great. The mod is a little different on our cars because the wiring harness used, uses some different wire colors. There is no Light Green Hand Brake wire going to the back of our unit, like the mod calls for, at least there wasn't on mine. The Hand Brake wire on our car, if I remember correctly is a Red & White wire. It will be the third wire over from the Black wire on the Black connector. The link below will show you the pinouts and it's the position 9 wire on the Power Supply connector is the one you want.

http://i13.photobuck... ... inouts.jpg

Hope this helps.....

#6 unix-guy

unix-guy
  • Members
  • 17 posts

Posted 13 August 2009 - 06:50 PM

I've got the 2009 Scion xB Release Series 6.0 - had it a couple of days now. I really like the F900BT.

A question for you guys - do you steering-wheel audio controls work? Mine don't and I plan to take it in to Scion this weekend to see what they say. Since its factory integrated, I think they should work...

So, I assume this Hand Brake mod is so that you can enter addresses when you are not parked? Can you also dial with the phone pad?

Thanks,

Kevin

#7 XBinRochester

XBinRochester

    Member

  • Members
  • 29 posts

Posted 13 August 2009 - 08:59 PM

I've got the 2009 Scion xB Release Series 6.0 - had it a couple of days now. I really like the F900BT.

A question for you guys - do you steering-wheel audio controls work? Mine don't and I plan to take it in to Scion this weekend to see what they say. Since its factory integrated, I think they should work...

So, I assume this Hand Brake mod is so that you can enter addresses when you are not parked? Can you also dial with the phone pad?

My steering wheel controls work fine with the F900BT on my RS6.

The "Hand Brake Mod" will allow you do do "everything" while driving, even watch a DVD, though it's not recommended. LOL

#8 unix-guy

unix-guy
  • Members
  • 17 posts

Posted 17 August 2009 - 06:40 PM

My steering wheel controls work fine with the F900BT on my RS6.

The "Hand Brake Mod" will allow you do do "everything" while driving, even watch a DVD, though it's not recommended. LOL


Thanks! Sorry - I didn't have notifications turned on :)

I guess I need to take my xB in to the service department then, because my audio controls on the wheel do nothing!

I think I'll try to live without the mod for now - probably safer for me :)

#9 XBinRochester

XBinRochester

    Member

  • Members
  • 29 posts

Posted 20 August 2009 - 11:01 AM

Thanks! Sorry - I didn't have notifications turned on :)

I guess I need to take my xB in to the service department then, because my audio controls on the wheel do nothing!

I think I'll try to live without the mod for now - probably safer for me :)

Let us know how it goes. The Mod is nice since it will allow you to put in an address for the Nav without having to pull over and engage the emergency brake!

We used it last night and it was great not having to pull over and stop.

#10 chrisdamato

chrisdamato
  • Members
  • 7 posts

Posted 20 August 2009 - 07:17 PM

Thanks guys, it's great to make contact with other RS6 owners! xbin* thanks a lot for the mod help!

Kevin, check the back of your unit to make sure the wired remote is plugged in. It's a little plug that looks like a mini headphone jack. The avic is installed by hand at the port, I think, and it would be easy for any installer to miss this.

The service dept might do a good job but you might be able to fit it yourself. Just pull off the fascia around the radio and then undo the bolts you see.

Tip: put a think blanket or pillow on the console where you will rest the head unit, there are a lot of sharp edges that could mess up your nice new car.

#11 unix-guy

unix-guy
  • Members
  • 17 posts

Posted 20 August 2009 - 07:59 PM

Awesome, Chris. Sounds like the facia is similar to the 2000 Durango I traded in for the RS6 - pop it off and undo a couple screws to pull the deck. I'll take a look at that today - thanks!

#12 XBinRochester

XBinRochester

    Member

  • Members
  • 29 posts

Posted 21 August 2009 - 12:37 AM

Thanks guys, it's great to make contact with other RS6 owners! xbin* thanks a lot for the mod help!

No problem, it's nice to know there is a place to come for the answers. I just updated my F900BT with the new software update, I'll keep you posted!

#13 unix-guy

unix-guy
  • Members
  • 17 posts

Posted 22 August 2009 - 12:08 AM

Ok - I was able to get the audio controls on the wheel working. The wired remote was plugged in to the "digital output" jack. I plugged it in to the correct jack and all is well.

While I was in there I removed the cable wrap on the iPod/USB cable and ran in out the bottom of the dash rather than in the glove box. Now I have more flexibility on where I put my iPhone :)

I didn't get to the handbrake mod yet, but that's next...

Kevin

#14 unix-guy

unix-guy
  • Members
  • 17 posts

Posted 22 August 2009 - 12:43 AM

I've read several posts on the hardwire bypass and I think I know what to do. Can someone confirm:

1 relocate mute wire
2 ground the relocated mute wire and the parking brake wire

is that it?

Kevin

#15 XBinRochester

XBinRochester

    Member

  • Members
  • 29 posts

Posted 22 August 2009 - 01:47 AM

I've read several posts on the hardwire bypass and I think I know what to do. Can someone confirm:

1 relocate mute wire
2 ground the relocated mute wire and the parking brake wire

is that it?

That's it! Just be careful, my RS6 didn't have a light green parking brake wire like all the mod's say to ground, mine was a different color.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Google (1)