Jump to content
AVIC411.com
dervbas

Testing your mods on a Virtual AVIC - WINCE

Recommended Posts

Hello all,

 

Some of you must have already considered how good it would be to test any mods/hacks you have done on a virtual machine on your PC instead of going outside into your car each time, especially when its a case of trial and error!

 

virtual-avic.jpg

 

You can download Microsoft Virtual PC from here for free directly from Microsoft of course, but how can you put a copy of Windows CE on it? If you could install Wince on a virtual PC, surely you could copy the contents of the AVIC flash drive onto it and have a virtual Pioneer AVIC on your PC to test on?

 

Any experts out there have any views? Have you tried it? Were you faced with problems?

Share this post


Link to post
Share on other sites

VirtualPC won't work as an AVIC emulator because the AVIC uses an ARM based processor, while your PC uses an x86 based one. You need to follow the instructions in the Wiki under the "OS Emulation" article to install the Device Emulator and WinCE images. Also search under the Hacks & Mods forum for Emulator (this link is probably the most relevant).

 

"Any sufficiently advanced technology is indistinguishable from magic." - Arthur C. Clarke

Share this post


Link to post
Share on other sites

Thank you very much FourG, I followed the instructions set in the Wiki http://avic411.com/wiki/index.php/OS_Emulation and have my headunit working like-for-like on my desktop PC now! :D

 

***edit: Only the main menu loads and there's already been discussions about getting the Navi to load - it simply won't so this whole thing is pretty useless I'm afraid***

 

To complete this thread, let me remind everyone that you can download a factory backup of the F900BT software from this AVIC411.com pin'd thread:

 

http://www.avic411.com/forum/viewtopic.php?f=34&t=18977

 

Thanks again FourG.

Share this post


Link to post
Share on other sites
Thank you very much FourG, I followed the instructions set in the Wiki http://avic411.com/wiki/index.php/OS_Emulation and have my headunit working like-for-like on my desktop PC now! :D

 

***edit: Only the main menu loads and there's already been discussions about getting the Navi to load - it simply won't so this whole thing is pretty useless I'm afraid***

 

To complete this thread, let me remind everyone that you can download a factory backup of the F900BT software from this AVIC411.com pin'd thread:

 

viewtopic.php?f=34&t=18977

 

Thanks again FourG.

 

I'm nearly there... I've got the emulator working running wm6.1 but just need to know which image / link to download for the F900BT software. Can you link direct to it please m8 ?

 

The only one I've found is an igo one, but I wanted a full one so I can play.

 

thanks

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×