Jump to content


Photo

x920bt firmware and map upgrade to CNSD-210FM for free?

x920bt

  • Please log in to reply
101 replies to this topic

#1 Starseed99

Starseed99
  • Members
  • 10 posts

Posted 26 December 2011 - 07:00 PM

Hi All,

First off i must say I love this site and have been using for years, ever since I first bought my Z1, I've followed upgrade instructions switching hds, map upgrades the works... Even my f900bt had all the upgrades thanks to the fx3.1 patch and the mods.... So I really have to say you guys in this domaine are amazing...

But alas my last two avics are gone now (stolen :?) and I now have a brand new slightly used demo of a x920bt, cost $400 at bestbuy as an open box...

So here is the story so far installed the unit into my car from previous Z1 install, and I've done the bypass parking/mute move and grounded them... Unit works perfect with all functions enabled, so I then installed the new firmware to 2.03 from pioneer all works perfect...

So now ofcourse I'd like the new maps 2011 and 3.0 firmware from the CNSD-210FM and would like for free as everything I've ever done from here has been :mrgreen:

So I'm reading everything I can and it seems you can upgrade the eu models by flashing a special upgrade to version 2.04 and then downloading the EU update and applying it with no password...

Has anyone state side tried this with their x models?

I'm thinking what would work is to start with firmware 2.03 and upgrade again using the modified version to 2.04 using the StefanSki 2.004 crack

http://avic411.com/i...attach_id=14745

Then downloading the map update pack for US models from here

http://thepiratebay....M_US_CAN_UPDATE

Has anyone tried this at all, Im a little hesitant since its kinda combining a EU crack and a US crack together and like always I know things can brick but hey testing is a fun thing to do....

Anyone try this? Or something similar, would be nice to have everything updated and new

#2 SolidForce

SolidForce
  • Members
  • 10 posts

Posted 27 December 2011 - 04:29 PM

Did you try it?

#3 JohnnyDepp

JohnnyDepp

    Member

  • Members
  • 238 posts

Posted 27 December 2011 - 10:27 PM

But alas my last two avics are gone now (stolen :?) and I now have a brand new slightly used demo of a x920bt, cost $400 at bestbuy as an open box...


Sounds like you live in a bad part of town. Also, didn't realize Best Buy was still selling any Pioneer models of this...thought they stopped a couple of years ago. Hmm....interesting. Sure it was an "open" box and not a "stolen" box?

#4 Starseed99

Starseed99
  • Members
  • 10 posts

Posted 28 December 2011 - 12:16 AM

HI Johnny, yeah I do live in a bad part of town and thanks for the concern, and yes a bestbuy did have this as an in store demo for a year and half and never sold it, very interesting isn't it... So yes I'm sure it is an open box and I even purchased a 2 year extended garantee from them as it was a demo... So hopefully that answers your questions...

Back to the subject at hand, I'm guessing no one has tried this? Guess I'll try it out tonight and I'll let everyone know how it goes

#5 Starseed99

Starseed99
  • Members
  • 10 posts

Posted 28 December 2011 - 02:36 PM

Ok so I confirm this works and the unit is updated with no problems, I wanted to wait till I drove 50 kms before posting that it works just in case...

The procedure is quite easy, download the crack above and the official 2.03 update from pioneer, overwrite the two files in the official update and put that on a SD card and the system will update to version 2.04

Next once that is done, take the SD1 dir from the update file and put that on a SD (needs to be bigger then 2gig) insert SD like normal and the system will ask a few questions say yes/ok to all and once you are presented with a question for the password type the following on screen PASSWORDPASSWORD and hit ok. Should take about 22min to update and restart...

Now take the SD2 directory from update and put on the sd and insert that go into the bluetooth settings and then firmware update to start that update it will goto 3.22

So everyone can now enjoy new maps and firmware 3.01 as per the above files...

I've only tested this on the x920bt and have no idea what it will do to other units

#6 MaStA

MaStA
  • Members
  • 9 posts

Posted 29 December 2011 - 01:36 AM

Ok so I confirm this works and the unit is updated with no problems, I wanted to wait till I drove 50 kms before posting that it works just in case...

The procedure is quite easy, download the crack above and the official 2.03 update from pioneer, overwrite the two files in the official update and put that on a SD card and the system will update to version 2.04

Next once that is done, take the SD1 dir from the update file and put that on a SD (needs to be bigger then 2gig) insert SD like normal and the system will ask a few questions say yes/ok to all and once you are presented with a question for the password type the following on screen PASSWORDPASSWORD and hit ok. Should take about 22min to update and restart...

Now take the SD2 directory from update and put on the sd and insert that go into the bluetooth settings and then firmware update to start that update it will goto 3.22

So everyone can now enjoy new maps and firmware 3.01 as per the above files...

I've only tested this on the x920bt and have no idea what it will do to other units


I have a x920bt as well so maybe I will try this out. So the maps in the torrent are definitely USA/Canada maps and not Europe, etc.? I just don't want to update it and be stuck with some foreign countries maps lol.

Also, is the unit really getting updated to 2.04 or is it just making it show as being updated to 2.04 so it will accept the new map pack update?

Thank you.

#7 Starseed99

Starseed99
  • Members
  • 10 posts

Posted 29 December 2011 - 07:08 PM

HI MaSta, yes to confirm the maps are for US/CAN from the link above, and when you update to 2.04 it only updates one or two files so you can update to 3.01 and new maps

#8 Cerapus

Cerapus
  • Members
  • 6 posts

Posted 29 December 2011 - 09:56 PM

I'm not sure what I'm doing wrong here. I've done the Stefanski crack and that seems to have loaded without a problem. I've downloaded the CNSD-210FM torrent and extracted the .rar file to my SD card. Everything is in a directort called SD1 which is on the root directory. Nothing happens when I insert the SD card. I've tried turning the car off and restarting with the SD card in the slot and I've tried inserting it during startup and I've tried inserting it after startup. Nothing happens.

I've also tried moving the SD1 folder into an AVICZ110 folder on the SD. Same thing. Any ideas?

#9 Starseed99

Starseed99
  • Members
  • 10 posts

Posted 29 December 2011 - 10:35 PM

Put everything from the SD1 directory to the root of the sd card and it will work

#10 MaStA

MaStA
  • Members
  • 9 posts

Posted 29 December 2011 - 11:26 PM

Awesome! Thank you very much for testing this out and letting us know it works. My friend mailed me a 16GB micro SD card yesterday so once I get it I will update and post back some hopefully positive results.

Thanks again!

#11 Cerapus

Cerapus
  • Members
  • 6 posts

Posted 30 December 2011 - 04:04 PM

Yup! That did the trick! It's working perfectly and completely updated now. Thank you!

#12 MaStA

MaStA
  • Members
  • 9 posts

Posted 04 January 2012 - 01:53 AM

I did all the updates today. I will say that when I used the 2.03 update with the modified files and went to system information after updating it, it said the version number was 2.00000, not 2.03. I went ahead and did the SD1 and SD2 updates and the version number now says 3.00000 and not 3.01. I wonder why this is...everything seems to have updated and seems to be working fine (haven't drove yet). Am I checking in the correct place for the version number...?

Thanks!

#13 Cerapus

Cerapus
  • Members
  • 6 posts

Posted 04 January 2012 - 02:14 PM

I did all the updates today. I will say that when I used the 2.03 update with the modified files and went to system information after updating it, it said the version number was 2.00000, not 2.03. I went ahead and did the SD1 and SD2 updates and the version number now says 3.00000 and not 3.01. I wonder why this is...everything seems to have updated and seems to be working fine (haven't drove yet). Am I checking in the correct place for the version number...?

Thanks!


On the screen that gives you your software version, you have to press and hold your finger in the top right hand corner and the specific version comes up. There is no button to press and it may take a number of tries to hit the sweet spot.

#14 MaStA

MaStA
  • Members
  • 9 posts

Posted 04 January 2012 - 11:10 PM


On the screen that gives you your software version, you have to press and hold your finger in the top right hand corner and the specific version comes up. There is no button to press and it may take a number of tries to hit the sweet spot.


So on the system information screen where I see the 3.0000 number and some alpha numeric ID is where I touch and hold in the top right corner to get something else to pop up? I tried and it didn't work for me.

Does yours say 3.0000 on the system information screen as well? Either way I think it updated fine since everything seems to be functioning properly...

Thanks!

#15 Cerapus

Cerapus
  • Members
  • 6 posts

Posted 04 January 2012 - 11:52 PM


So on the system information screen where I see the 3.0000 number and some alpha numeric ID is where I touch and hold in the top right corner to get something else to pop up? I tried and it didn't work for me.

Does yours say 3.0000 on the system information screen as well? Either way I think it updated fine since everything seems to be functioning properly...

Thanks!


That's the place, but like I said, it took a while before I found the right spot. Anyway, sounds like you've got it working regardless.





Also tagged with one or more of these keywords: x920bt

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users