Jump to content
AVIC411.com
pionara

2012 US/CAN Maps - CNSD-310FM/UC upgrade (updated to supereasymethod - beta)

Recommended Posts

UPDATE: I have found a super easy method to install. No testmode, no hacked dlls, etc.

 

1. get the update and put it on an SD card (like below) so that the SD card has Cardinfo.cif, Update, Firmware folders at the top (root) level of the sd card.

2. replace the file on sd card: \Update\VERINFO.DAT with this one:

 

3. if you have Z110, Z120, or X920 (not needed for Z130 or X930): Replace the Cardinfo.cif on the SD card with this one that is inside this zip:

cardinfo.dat.zip

4. insert SD card into unit (make sure you have good power to your vehicle - running, battery charger, etc)... it should ask to upgrade and reboot... no password needed. Will take about 30 mins. After it has completed update it will restart and go through initial settings like voice, etc. It should reboot and you should see 2012 splash screen. After the unit reboots, it may ask you if you want to update again but choose NO (provided update went ok and you have 2012 splash screen which means it updated.)

5. update your bluetooth firmware (to 3.24) in the bluetooth settings menu

 

please report your success on this thread. If you have problems, make sure you note your current model and version.

 

update: IAmSuperBleeder posted a nice step-by-step with photos: #301

 

- applies to x930bt, x920, z110, z120, or z130 US/CAN models. This is for CNSD-310FM/UC- UC means US/Can. No EU updates or other regions yet. The procedure should be the same for F10,20,30 and F920, F930 as soon as there is a Euro version available.

For Euro (EU5) update here: http://avic411.com/i...eu-2012-update/

 

update: torrent of the full update image posted here: #204

 

after upgrade:

service information screen. hold top left for detailed info:

Platform version: 4.000

Application version: 4.010

Version: 4.000

.....

Bluetooth firmware version: 3.24

 

if you like the new version/maps, please do yourself a favor and go pay for it.

Note: it is up to you to legally obtain the update files. I have provided an alternate method of installation that does not require a password for those folks with legally obtained software.

Edited by pionara

Share this post


Link to post
Share on other sites

i had to download the appradio app to get appradio mode working.

it's ok i guess. i think it just mirrors certain compatible (native and 3rd party) apps out on the video display.

What would be cool if pioneer would release the specs on how to make your app appradio compatible.

Share this post


Link to post
Share on other sites

THANK YOU! So far working like a charm! I say working cause I still have 13min left on the first pass. But it's updating! :) Thank You pionara for the hack and sheka for the update!!!!!

 

Update.... Install went perfect as described. in fact the maps seem better in the respect of looking for Point Of Interest. They are no longer messed up and in a weird order. At least this was the case on my uunit before upgrade. Thanks again!

Share this post


Link to post
Share on other sites

Thanks! Just what I needed. Updating right now. X930bt and x9310bt. Hopefully it'll fix my problems. Crosses finger! Much thanks to sheka and pionara!

Share this post


Link to post
Share on other sites

netwalkr101, can you indicate which model you had. Want to verify it works good on all the expected ones.

Yes it was the X930bt and had the 2011 maps. I also copied the RenewalIFLib.dll to both PRG0 and PRG1. Just because a few extra steps couldn't hurt.

Share this post


Link to post
Share on other sites

Just upgraded from Z130bt to Z140bt.

 

Took me about an hour to figure out why the upgrade wasn't loading after following the above directions.

 

For some reason the CARDINFO.cif file wasn't compatible with the Z130bt.

 

You need to replace it with the CARDINFO.cif file from

 

http://avic411.com/index.php?/topic/32362-z110bt-usa-upgrade-with-csnd-210fm-2011/page__st__105&do=findComment&comment=238040

Share this post


Link to post
Share on other sites

Are the RenewalIFLib.dll and CARDINFO.cif device specific? If not, can someone help package those two files for easier 130BT upgrade? I'm just not comfortable with testmode.. Actually don't know how to use it at all.

Share this post


Link to post
Share on other sites

A package would be awesome - I, for the life of me, can't get ANY test mode to work. Does anyone have working/updated testmode files for a z130bt? I've been searching the forums for hours trying to find them, and everything i find and extract to my SD will not boot.

Share this post


Link to post
Share on other sites

A package would be awesome - I, for the life of me, can't get ANY test mode to work. Does anyone have working/updated testmode files for a z130bt? I've been searching the forums for hours trying to find them, and everything i find and extract to my SD will not boot.

 

They are in the condi hackmode thread. Put the testmode,key in the root of the sd card.

Share this post


Link to post
Share on other sites

They are in the condi hackmode thread. Put the testmode,key in the root of the sd card.

 

Had a hunch the zip file was being corrupted, and it was. I was doing it on a mac, and it wasnt extracting testmode.key/hackmode.key/or the read me. I started up a windows 7 VM, and unpackaged it and everything was there. Weird, wonder if any other mac users noticed this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×