Jump to content
AVIC411.com
adamleerusse

hybrid 4.0 avic-f900bt

Recommended Posts

Hi there.

 

I've been following this topic, and searching others.  I have a Pioneer AVIC-F9220BT that was given to me.  Firstly, the BT has stopped, and I only have ---'s for BT firmware version, but know thats due to a borked BT chip, I've found that already but also haven't found a later bt version to try and reflash with.

 

Secondly the maps are the original version, and the firmware is 02.0000.  I've never played with this type of kit before so am learning.  Are there some nice instructions somewhere to follow to update to this hybrid version?  I've download and extracted the files, but am a little confused what to do with wince. I've found latest UK maps for igo, so am all set and want to play,

 

Can anyone help me at all? Many thanks =D

Share this post


Link to post
Share on other sites

Just download the 4.0 files from wherever (piratebay)...

 

Get a set of maps (you can use the old maps or update them).

 

Put the maps, POIs, DEMs, in the respective /ap2/iGo/content files...

 

Put all the (updated with maps) files from 4.0 download onto an sd card.

The files are: The copy file (with all the AP1, 2, 3...)

Data,zip

testmode (file)

wince (bin file)

wince (cks file)

 

At this point you can follow the 3.0 install sticky guide...

put in the card, start up the car... hold all four buttons... let go of the reset button, keeping your fingers on menu+map...

@ the blue screen: up, up, down, menu, left, right... option 0=wince upgrade... option 0=wince (format)...

That will format the APIs folder on the flash disk.

press reset... let it load into the testmode...

Open commander and copy all the copy folder onto the flash disk.

Move the data.zip into the correct place...

press reset... voila!

 

There are better instructions out there, though... Use the readme and the 3.0 upgrade for reference.

 

There can be a LOT of hiccups in these installs. I had several issues with memory... the new maps were slightly too big to fit on my scant 1.8GB flash memory of the 700BT, so I had to edit the map list to the relevant ones. If you dont, and you fill your memory, you won't be able to start up the navi in regular or testmode... so, it's REALLY important not to leave testmode with less than 100MB available. Thats just for safety...

Share this post


Link to post
Share on other sites

Just download the 4.0 files from wherever (piratebay)...

 

Get a set of maps (you can use the old maps or update them).

 

Put the maps, POIs, DEMs, in the respective /ap2/iGo/content files...

 

Put all the (updated with maps) files from 4.0 download onto an sd card.

The files are: The copy file (with all the AP1, 2, 3...)

Data,zip

testmode (file)

wince (bin file)

wince (cks file)

 

At this point you can follow the 3.0 install sticky guide...

put in the card, start up the car... hold all four buttons... let go of the reset button, keeping your fingers on menu+map...

@ the blue screen: up, up, down, menu, left, right... option 0=wince upgrade... option 0=wince (format)...

That will format the APIs folder on the flash disk.

press reset... let it load into the testmode...

Open commander and copy all the copy folder onto the flash disk.

Move the data.zip into the correct place...

press reset... voila!

 

There are better instructions out there, though... Use the readme and the 3.0 upgrade for reference.

 

There can be a LOT of hiccups in these installs. I had several issues with memory... the new maps were slightly too big to fit on my scant 1.8GB flash memory of the 700BT, so I had to edit the map list to the relevant ones. If you dont, and you fill your memory, you won't be able to start up the navi in regular or testmode... so, it's REALLY important not to leave testmode with less than 100MB available. Thats just for safety...

Share this post


Link to post
Share on other sites

You'll have to pardon my last post. Not that anyone will read this in a month or so, ha. I'll remove it tomorrow when I'm on a computer (phone as of right now)

 

I'm just curious to know, I have a fb900bt (usa) that came with the car I just purchased recently; unfortunately its stock, the firmware that is. V1. Can I just update windows ce to 6 and install this hybrid 4.0? Or do I have to get each update? Thanks in advance.

Share this post


Link to post
Share on other sites

I'm sorry with an extra 20 minutes I found all my answers. Seriously sorry for the triple posts.

 

Anyone from USA should proxy their browser like mentioned a billion times.

Pardon.

Share this post


Link to post
Share on other sites

I will be trying this on my AVIC-X9115BT and let you know if it works. I am also having the boot loop with "System Startup in Progress... Please wait". 

 

Fingers crossed because I don't wanna spend money on ebay for this; http://www.ebay.com/itm/2013-Q3-PIONEER-AVIC-X9115BT-AND-AVIC-X7115BT-USA-Q4-GPS-MAPS-SOFTWARE-REPAIR-/141260020101?pt=LH_DefaultDomain_0&hash=item20e3c0d985

 

 

but might have to if no luck. Started the download.. taking about 2 hours.. will update when tried.

Share this post


Link to post
Share on other sites

If you live in the US you will need a proxy to download files.

 

Transferred to the sd card (didn't add any maps, mainly because I couldn't find the proper one's for the us).

 

Followed the provided instructions with the readme file.  (below)

 

Transfer all files inside the hybrid-4.001 file to the sd card. (yes all of them)

 

insert sdcard in unit
to enter uboot mode, flash new OS (winceimg.bin), and format My Flash Disk:
power up while holding reset, eject, menu, & map
release reset, but keep holding eject, menu, & map
blue screen: "please push reset key again"
enter sequence: up, up, down, menu, left, right
choose "0=WINCE Upgrade"
choose "0=WINCE by SD/MMC (Format)"
 
leave sdcard inserted until all on screen prompts are completed, then press the restart button.
 
update application:
with sdcard inserted, unit should boot into "Testmode" (windows explorer desktop with a few utilities).
Use explorer or total commander to copy contents of "\Storage Card\copy_contents_to_My_Flash_Disk" to "\My Flash Disk"
(one method: select the folders/files in the folder, copy, navigate to My Flash Disk, and paste)
My Flash Disk should contain the folders like APL, APL2, etc.
 
this may take a while (15-20 mins?)
 
when copy is complete, remove sdcard
reset unit
unit should boot up and go through initial setup (language, etc), then reboot a final time.
 
 
That was it, selected my language and everything was working perfect!
 
Next im gonna add some maps.
 
Unit: AVIC-X9115BT

Share this post


Link to post
Share on other sites

This seems to be the newest maps available but I havent tried them yet.  I would be interested though as I do have some 2013 Q1 maps and a lot has changed since then.

These are 2014 Q3 maps here

http://www.ebay.com/itm/GPS-Repair-2015-Map-Update-Pioneer-Avic-F900BT-F90BT-F700BT-Deluxe-4-001-/181449294873?pt=LH_DefaultDomain_0&hash=item2a3f388419#ht_1371wt_1026

Share this post


Link to post
Share on other sites

Hy Guys i have a question

 

My Build was v3.

 

Now i have updated to the posted Version 4. But not the regular way i think: I have replace all the files in the APL Folders with the newer ones.

I have not Update the Win CE image. Is this ok? Cause my win ce image is Version 5 is this the version 6? Because the date modified on the files are not the same. I have taken my old ezrider to use my old maps and my sys.txt for the Settings. My Unit works but im not shure that was the right way to update. In system Settings i have now a DebugMode with a few features is this correct? Thank you very much.

Share this post


Link to post
Share on other sites

Hi All,

 

When I try to open the guide from google I get the message error topic does not exist..

 

Is there a reason for this?

 

I've found what I think is the correct software if this helps anyone..

Can someone help me with the correct method?

 

Thanks!

 

http://www.mediafire.com/?fk177j7sk65d5pd

http://www.mediafire.com/?j4agh9jemp2ml0c

http://www.mediafire.com/?dhsy1fe8m50vaks

 

thank you, followed instructions included in the archive and successfully updated f910bt to v4.001. 8)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×