Jump to content
AVIC411.com
crankz

AVIC-MRZ99 Custom Firmware / Testmode

Recommended Posts

Hello.
There is mrz009.
How to in to the testmode to change the language.

Testmode.key from DZO is not suitable.

CAUTION!

TEST MODE FAILED STARTING!

[Turn off ACC]

avic-mrz009.jpg

Share this post


Link to post
Share on other sites
On 17.04.2018 at 11:15 PM, SergVDK said:

Hello, dear friends.

First of all, I want to sincerely thank DZO for the excellent work. The materials were very useful in practice.
Now i have a big problem with my Carrozeria AVIC-MRZ99, which I can not solve on my own.
I put the English language on the instructions from DZO, read the entire forum branch, but did not find a solution anywhere.
I do not have a bluetooth operation, it does not configure and does not connect to devices.
In the settings menu, the system requires a password change, but all windows are inactive, and I do not know how to change it and make it work (photo in attachments).

As far as I understand, it can be done through the firmware, diagnostic menu or something like that.
It can be a replacement for the file responsible for the bluetooth password.
Nowhere in the settings did I manage to change the password and make BT work.
I'll be glad if you can help me at least somehow.

I hope for your responsiveness and sociability.

Приветствую, друзья.
У меня есть проблема с Carrozeria AVIC-MRZ99, которую я никак не могу решить самостоятельно.
Сначала хочу от всей души поблагодарить DZO за прекрасную работу. Материалы оказались очень полезными на практике.
Я поставил английский язык по инструкции от DZO, прочитал всю ветку, но нигде не нашёл решения своей проблемы.
У меня не работает Блютуз, не настраивается и не подключается к сторонним устройствам.
В меню настроек Bluetooth система требует "смены пароля", но все окна - неактивны, и я не знаю, как его поменять и заставить BT работать (фото во вложениях).
Насколько я понимаю, это можно сделать через программное обеспечение, прошивку, диагностическое меню или что-то подобное.
Может быть заменой файла, отвечающего за текущий пароль блютуза?
Нигде в настройках мне не удалось поменять пароль или сделать что-то другое, что бы заставить Bluetooth работать.
Буду рад, если Вы сможете мне хоть как-нибудь помочь.
Надеюсь на вашу отзывчивость и коммуникабельность.

5ad5ef92a6ca6_BTProblem.thumb.jpg.db361cd8183bce549184c3d2dbcfb659.jpg

Rus: Поставьте машину на ручной(ножной) тормоз. По русски ручник. Сигнал с ручника должен попадать на AVIC. Во время движения многие настройки запрещены. Так же, у Вас может быть электрическая проблема с сигналом от ручника до головного устройства. 

Eng: Place the machine on the handbrake (foot) brake. The signal from the handbrake should fall on the AVIC. While driving, many settings are prohibited. Also, you may have an electrical problem with the signal from the handbrake to the head unit.

Untitled.png

Share this post


Link to post
Share on other sites

1. Is it possible to change the language for AVIC-MRZ099?
2. How to switch to test mode, if there is no "left" and "right" button?

 

picture (3).jpeg

picture (2).jpeg

Share this post


Link to post
Share on other sites

 

I have a very serious problem! Deleted the folders PRG1 and PRG0, replaced the files of others PRG1 and PRG0 not my version. Now I have only the logo mazda and so on the circle. I can not get to the service menu "Left, right, left, right, left, right" menu does not work. Previously, it worked. The script does not work either. It turned out brick. What to do?:?:

Share this post


Link to post
Share on other sites
20 hours ago, MarioFly said:

1. Is it possible to change the language for AVIC-MRZ099?
2. How to switch to test mode, if there is no "left" and "right" button?

 

picture (3).jpeg

picture (2).jpeg

See the post on page 32 by marcdane.

Share this post


Link to post
Share on other sites
12 hours ago, barsyk said:

 

I have a very serious problem! Deleted the folders PRG1 and PRG0, replaced the files of others PRG1 and PRG0 not my version. Now I have only the logo mazda and so on the circle. I can not get to the service menu "Left, right, left, right, left, right" menu does not work. Previously, it worked. The script does not work either. It turned out brick. What to do?:?:

if you have mrz05 try these files. try to remove any usb, dvd and sd card. keep the button pressed while turning on the key switch and try left,right........Best of luck.

AIPI_Av.dll

AIPI_Common.dll

AIPI_Download.dll

AIPI_HMIManager.dll

AIPI_Navi.dll

AIPI_PServer.dll

AIPI_SvrAcc.dll

AIPI_Voice.dll

AplCommonLib.dll

AplLib.dll

Av.exe

AvVinCoreBase.dll

Download.exe

HMIManager.exe

ImageControlLib.dll

Guide.CHN

Guide.ENG

Guide.JPN

Guide.KOR

NA090JPDHT.LNG

NA090JPMZD.LNG

NA090JPNSN.LNG

NA090JPSBR.LNG

NA090JPSZK.LNG

PF090JPENG.LNG

PF090JPJPN.LNG

PF110JPENG.LNG

PF110JPJPN.LNG

PF110JPMEN.LNG

PF110JPMTB.LNG

Av.rff

Download.rff

HMIManager.rff

Image.img

Navi.rff

Navi.exe

NSControlLib.dll

NSLib.dll

PServer.exe

RenewalIFLib.dll

SvrAcc.exe

SvrAccLib.dll

SymbolLib.dll

TelLib.dll

Voice.exe

VoiceLib.dll

PF110BOT.PRG

PF110DTV.PRG

PF110DTD.DAT

DFHSMaruGothic.pgf

PF110APL.HTM

PF110APL.VER

PF110BOT.HTM

PF110BOT.VER

PF110DTD.HTM

PF110DTD.VER

PF110DTV.VER

PF110FNT.HTM

PF110FNT.VER

PF110PLT.HTM

PF110PLT.VER

PF110PLT.PRG

PF110RGD.PRG

A11K01KM.WAV

A22K01KM.WAV

MONO11KN.WAV

MONO22KN.WAV

HITO1_VGA.JPG

Thumbs.db

OnesegCoreTest.exe

Share this post


Link to post
Share on other sites
On 5/16/2018 at 7:47 AM, barsyk said:

 

I have a very serious problem! Deleted the folders PRG1 and PRG0, replaced the files of others PRG1 and PRG0 not my version. Now I have only the logo mazda and so on the circle. I can not get to the service menu "Left, right, left, right, left, right" menu does not work. Previously, it worked. The script does not work either. It turned out brick. What to do?:?:

Put this testmode key onto a usb stick or sd card:

TESTMODE.KEY

And switch on the unit.

If this doesn't bring up testmode then there is nothing much you can do.

If it gets you into testmode, then you will need to find somebody else with the same model as yours and copy their PRG0 folder.

You should never have deleted the PRG folders

Share this post


Link to post
Share on other sites
On 20.05.2018 at 9:52 AM, dzo said:

Put this testmode key onto a usb stick or sd card:

TESTMODE.KEY

And switch on the unit.

If this doesn't bring up testmode then there is nothing much you can do.

If it gets you into testmode, then you will need to find somebody else with the same model as yours and copy their PRG0 folder.

You should never have deleted the PRG folders

you can run a script that will copy the files from the USB stick to the device. But first, as you said, you need to find the original files.

 

(I'm not sure about syntax.) ScriptExec.ini :

COLOR 48
ECHO
ECHO  Recovery files
ECHO
SLEEP 3000
ERROR OFF
ECHO ON
COPY -c USB\PRG1 USER\PRG1\
COPY -c USB\PRG0 USER\PRG0\

COLOR 21
ECHO
ECHO
ECHO  Done
ECHO
ECHO
ECHO
SLEEP 5000
RESET
ECHO RESET
RESET 1

 

Share this post


Link to post
Share on other sites

Dear dzo please find some time for me.
I have a Pioneer Carrozzeria AVIC-ZH0009cs.
Can you help me translate into English?
The fact is that in the folder
NX168 \ PRG0 \ APL \ Resource \ LANGDATA
no files with the .LNG extension
Tell me please where else can you search phrases and words in Japanese for translation?

Here is my NX168  folder.

Sorry for my English, I use a translator.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×