Jump to content
AVIC411.com
crankz

AVIC-MRZ99 Custom Firmware / Testmode

Recommended Posts

On 21.11.2019 at 9:16 AM, mattmoo138 said:

Hi Guys i have purchased a volvo xc90 with a AVIC-HRV22... I cannot even find a way of getting into the test mode, im not even sure this has usb.. has anyone any idea if its possible to update the language files?

Судя по описалову в интернете, у тебя блок ДВД + монитор. Я, конечно, не спец, но предположу, что твоя система далеко не на Windows Mobile или чем-то похожем.
Как мне кажется, у нее нет ничего похожего на testmode.

 

Share this post


Link to post
Share on other sites
3 hours ago, Alex75rus said:

How did you solve the problem?

Try turning on Bluetooth first and then try changing the password.
I have RZ-77, and while bluetooth is off, all settings are inactive.

Попробуй сначала включить Bluetooth и уже потом пробуй сменить пароль.
У меня RZ-77, и пока выключен bluetooth, все настройки неактивны.

Share this post


Link to post
Share on other sites
22 hours ago, Alex75rus said:

How did you solve the problem?

At first, select the Japanese mobile operator: docomo, au, SoftBank.

Сначала  надо выбрать японского оператора : docomo, au, SoftBank.  Тогда  блюпуп должен очнуться.

Share this post


Link to post
Share on other sites
On 25.11.2019 at 7:38 PM, Long Wire said:

At first, select the Japanese mobile operator: docomo, au, SoftBank.

Сначала  надо выбрать японского оператора : docomo, au, SoftBank.  Тогда  блюпуп должен очнуться.

Выбрать когда идут стартовые настройки или можно уже потом в меню? Он там выдает оператора и еще одна строка на иероглифах.

Кстати, в сервисном меню, когда нажимаешь на тест Bluetooth выдает BT OPEN ERROR

Share this post


Link to post
Share on other sites

hi, i got mrz07, i deleted pf.090jpjpn.lng from prg0 and prg1, and replace with new. restart and again japanese. i replace as well pf110jpjpn.lng in both places. restart still japanese language. what i can do more? just system let me change the backgroung image , replaced the file , restart and work.

Share this post


Link to post
Share on other sites

Добрый день , удалил с папки USER  avic-mrz 0047 все файлы, копии нет буду признателен если кто даст ссылку на файлы. Спасибо.

Share this post


Link to post
Share on other sites
On 4/10/2019 at 2:47 PM, EnoKt said:

Hi @dzo,

Your contribution is appreciated always. I jump boosted a battery to start my car  The AVIC MRZ09 shows the characters in Japanese shown below, translated  ''there is no program'' with number 7 at the bottom right of screen. The USER/DIŔ shows no content  Any help to revive this unit? I have original USER content backup and the English one from your previous posts. . I tried copying and  pasting the backups to the USER folder but nothing happens or shows up.  The Unit copies and pastes to any other media like FLASH DISC OR SD but does not paste in USER folder.. Any help  to revive it.? 

20190418_145120.jpg

Greetings, I have my avic mrz09 displaying the above screen of not loading programs and number 6 at the bottom any help on how to fix it. Regards

Share this post


Link to post
Share on other sites

Hey I'm new here. I have an rz33 and wanted to know how to get the map to show my country... Trinidad and Tobago. Also, I see no settings for Bluetooth and can the entire language be changed to english? It is the commercial model. 

Share this post


Link to post
Share on other sites
On 11/3/2016 at 5:45 AM, dzo said:

I've translated the Japanese language strings for the MRZ99 to English. 

I figured out the format of the LNG file, dumped the Japanese, translated all the strings using google translate, then rebuilt the file.

Some of the English is not perfect but it makes the system much more usable. 

 

I've tested it with APP firmware version 3.070200 (installed with platform version 3.000600), other versions may not work.

If the old language file is 93627 bytes long then this will almost certainly work.

 

To install this, unzip the attachment mrz99english.zip and put the PF090JPJPN.LNG file on an sd card. (130905 bytes, md5sum is cb3f9cb76330704cc171e2b0acb9f6ad)

Get into testmode by holding the NAVI button (left button with Japanese writing on it) and pressing right..left..right..left..right..left and then release NAVI.

 

Go to the last entry on the first page (File Maintenance in Japanese) and press MENU (right button with Japanese writing on it) 

This opens the file manager which is in English and fairly obvious.

 

Make a backup of /USER as described elsewhere on avic411.com

 

Look in /USER to see if there is a file named  PRG.FLG

if there is, then the system uses /USER/PRG1, otherwise it uses /USER/PRG0

 

You can check the file versions by looking at  /USER/PRGx/PF090APL.HTM (where x is 0 or 1 depending on PRG.FLG)

 

go to  /USER/PRGx/APL/LANGDATA/

 

delete  PF090JPJPN.LNG

go to /SD, copy the new PF090JPJPN.LNG and paste it into LANGDATA where the old one was.

 

Switch off the power and when it restarts, it should be in English....

 

This worked for me but obviously is not 100% safe, be very careful in the file manager.

 

Update: There's now an installer that also changes the background and most of the important images with japanese text.

 

Find it here:

 

https://github.com/dzo/mrz99/releases

mrz99English_v2.zip

Thank you sod much bro, finally I was able to change the japanese from English. can you please teach me how to change the gps zone? Its set for japan and Won't work in my country. I also Don't know how to download maps. 

I live in Bangladesh, Asia.

Thanks in advance :)     

Share this post


Link to post
Share on other sites

Dear dzo,

I have the exact nav system, i mean shape is exact I don't know the model, it is in Japanese as well but is from Mitsubishi. Will this work for Mitsubishi car navigation system as well? 

Please help!

Share this post


Link to post
Share on other sites
On 4/10/2019 at 2:47 PM, EnoKt said:

Hi @dzo,

Your contribution is appreciated always. I jump boosted a battery to start my car  The AVIC MRZ09 shows the characters in Japanese shown below, translated  ''there is no program'' with number 7 at the bottom right of screen. The USER/DIŔ shows no content  Any help to revive this unit? I have original USER content backup and the English one from your previous posts. . I tried copying and  pasting the backups to the USER folder but nothing happens or shows up.  The Unit copies and pastes to any other media like FLASH DISC OR SD but does not paste in USER folder.. Any help  to revive it.? 

20190418_145120.jpg

Please dzo try to assist in this issue which i asked and attached the image of the screen of MRZ09 on page 47.

Thanking you in advance for your time.

Share this post


Link to post
Share on other sites
On 9/6/2019 at 2:43 PM, Shtirlitz said:

Hi All!

FW backup instruction for AVIC-RZ09 (and similar devices - AVIC-RL09, AVIC-RW09, AVIC-RZ09, AVIC-RZ07, AVIC-RZ06, AVIC-RL05, AVIC-RZ05, AVIC-RW03, AVIC-RZ03):

1. Get SD card, FAT32-formatted. Probably the USB disk will work too, but I didn't check back up on USB.

2. Make the empty folder named "NAVIVUP" on SD card.

3. Power on the AVIC and place the SD card into AVIC device slot.

4. Go to in the Testmode (press and hold "NAVI" button, press each once right-left-right-left-right-left, release "NAVI" button - device restarted in test mode).

5. On the first screen - select menu "10. Program forced write", go to the next screen of this submenu (2 of 3) and select "3. Take out program".

6. Select destination "SD" or "USB" and press "MENU" for start downloading.

7. Wait for about minute while FW downloaded to SD/USD disk - with full-screen messages "!!NOW COPYING!!", while "HIT ANY KEY" message didn't appear.

Profit) You can see the full-FW files on your SD/USB disk in the NAVIVUP folder.

P.S.: Sorry guys but I cannot upload the screen-shots here, I see just "There was a problem uploading the file." message displayed.

Alex

This is backup instruction, Now how do yu upload English Language?

Share this post


Link to post
Share on other sites
19 hours ago, Mwassaru said:

This is backup instruction, Now how do yu upload English Language?

Hi @Mwassaru

Just use sources: https://github.com/Shtirlitz/RZ09

Cut 0x200 header of PRG-file - you'll get the .NB0 firmware.

Extract initDB.dat from .NB0 file, use my tools to make the translation.

Replace translated initDB.dat in the .NB0 and use makever.c to create updated FW files.

Here is step-by-step manual (2 posts): http://4pda.ru/forum/index.php?showtopic=847671&st=20#entry90149444

It's in Russian but I think it's easy to translate to English.

Good luck!

Alex

Share this post


Link to post
Share on other sites
On 21/11/2016 at 10:26 PM, dzo said:

 

The file manager isn't very intuitive, you need to navigate to the source file, highlight select and press menu so the file has a + beside it, then highlight copy and then press menu again, now navigate to the destination directory and move to any entry and then paste should be selectable. After you have pasted, be very careful because it highlights the next available operation which just happens to be "delete"!!

 

There's a youtube video showing how to use the file manager somewhere.

 

If you are still having problems, I can make a testmode script to do the copying.

For AVIC MRZ99 I could copy from SD but unable to paste into directory so I downloaded and tried using the installer changing paths to SD. Installer only changed image file but not language files, it gets stuck in a loop on image file. Is there an updated installer for SD so I can get the language files into both user directories?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×