Jump to content
AVIC411.com
Covert_Death

Upgrading NEX4000 to NEX4100 - Work in Progress

Recommended Posts

jump back should be super easy.

 

And yes CarPlay audio will not work either as this too is over Bluetooth i believe. I think everything comes back to that Bluetooth Audio "off" not being able to be triggered to "on". If we can get around that then we should have a pretty solid build.

Yep. I was able to jump back fine. No actually CarPlay runs everything including phone calls off USB. it's interesting to note that if I turned off CarPlay iPod audo would work off my phone, but with CarPlay on there is no sound.

Share this post


Link to post
Share on other sites

CarPlay audio worked just fine for me. However the microphone does not work, so there's very limited CarPlay functionality. I am currently running the newest iOS beta. Some settings are not accessible such as camera, but it still worked in reverse. My SiriusXM presets were adjusted to different channels but did not require a reset.

 

I do not have access to an android auto capable device right now, but there are many improvements to functionality in the firmware. New settings, such as the EULA screen coming at startup instead of at CarPlay launch (would love to see it just go away), and with new CarPlay settings in iOS 8.3 you can allow CarPlay without unlocking device, plug and play like android auto. New dimming settings are not acessible. It seems to be off to a good start though, great work. Thanks.

Share this post


Link to post
Share on other sites

covert_death let me know when you get the 6000 file

 

Curious on the bluetooth (possible CarPlay and Android Auto), could there be a difference in the bluetooth chip thats causing the no audio problem?  I am wondering if there were any hardware changes other than screen.

 

Speaking of screens, I am curious if its possible to upgrade the screen to the newer screens, once parts come available.

Share this post


Link to post
Share on other sites

CarPlay audio worked just fine for me. However the microphone does not work, so there's very limited CarPlay functionality. I am currently running the newest iOS beta. Some settings are not accessible such as camera, but it still worked in reverse. My SiriusXM presets were adjusted to different channels but did not require a reset.

 

I do not have access to an android auto capable device right now, but there are many improvements to functionality in the firmware. New settings, such as the EULA screen coming at startup instead of at CarPlay launch (would love to see it just go away), and with new CarPlay settings in iOS 8.3 you can allow CarPlay without unlocking device, plug and play like android auto. New dimming settings are not acessible. It seems to be off to a good start though, great work. Thanks.

 

are you running a beta iOS 8.3?  where would those settings be? Is it on the iPhone or the radio?  I have never seen any CarPlay settings on my iPhone (I'm running the current 8.2)

Share this post


Link to post
Share on other sites

It's only on iOS 8.3. Apple appears to be adding a lot more features presumably there's going to be a massive CarPlay rollout on vehicles in the next few months. I've only used beta 3 and 4 of iOS 8.3. Once connected I went to Settings -> general -> CarPlay. After connecting to a compatible receiver a list of my cars popped up and it appears as AV Receiver. Next to it is an info button press it, and you get two options. 1 Forget this car 2. Allow CarPlay when locked.

Share this post


Link to post
Share on other sites

It's only on iOS 8.3. Apple appears to be adding a lot more features presumably there's going to be a massive CarPlay rollout on vehicles in the next few months. I've only used beta 3 and 4 of iOS 8.3. Once connected I went to Settings -> general -> CarPlay. After connecting to a compatible receiver a list of my cars popped up and it appears as AV Receiver. Next to it is an info button press it, and you get two options. 1 Forget this car 2. Allow CarPlay when locked.

Thats cool. I stopped messing with beta's last year. wonder how much longer till they roll that out?

Share this post


Link to post
Share on other sites

8100 back to 8000 is up.

 

I'll check to see if the 7100 has a FW out yet, if so Im sure its the same and can try it.

 

anyone who tries on a device other than the 4000 can you please let me know if you are experiencing audio issues from the phone as well???

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×