Jump to content
AVIC411.com
Covert_Death

Upgrading NEX4000 to NEX4100 - Work in Progress

Recommended Posts

8100 back to 8000 is up.

 

I'll check to see if the 7100 has a FW out yet, if so Im sure its the same and can try it.

 

anyone who tries on a device other than the 4000 can you please let me know if you are experiencing audio issues from the phone as well???

 

i will test the 6000 for you if you like

Share this post


Link to post
Share on other sites

sweet...just saw it.  I will test it tonight when I get home.  I am going to assume the same issues.  Also, wondering if there will be an issue since the 6000 has an SD reader and the 6100 does not

Share this post


Link to post
Share on other sites

Updated my 8000 without problems. I thought I could outsmart the BT problem by replacing the bluetooth folder inside the firmware update with the bluetooth folder (as well as the PJ150BT.VER and PJ150BTL.VER files) from the 1.08 firmware. But no such luck, I'm having the same problems everyone else is having: no BT audio on neither music nor phonecalls. 

 

I tried un-pairing and re-pairing the phone, as well as resetting the BT settings on the NEX. No dice.

 

Also, it definitely takes a few seconds longer to boot.

 

I'm going back down to 1.08 for now and wait to see what king of progress Covert is making with this issue. Happy to test things out any time!

 

UPDATE: reverting back to 1.08 also worked without any problems

Share this post


Link to post
Share on other sites

iOS 8.3 is introducing wireless CarPlay.  I'm hoping the 4000NEX will allow for that.

 

My guess is that they have to issue an updated firmware.  I am afraid, we are in the dark.  Someone said (think Covert_Death) they heard somewhere we will get one more.

Share this post


Link to post
Share on other sites

My guess is that they have to issue an updated firmware.  I am afraid, we are in the dark.  Someone said (think Covert_Death) they heard somewhere we will get one more.

 

I suspect it won't.  The wireless CarPlay seems to be way more integrated into a car than an aftermarket headunit can provide.  I may be wrong, but the screenshot of the iOS 8.3 beta has you initiating the setup of wireless CarPlay by pressing the "talk" button on the steering wheel of your car.

 

Although I will try (again) the "Siri Hands Free" (or whatever it is called) button on my 4000NEX and see if that works instead.  I think I tried that already and nothing happened but I can't remember.

Share this post


Link to post
Share on other sites

 I am currently running the newest iOS beta.

 

and with new CarPlay settings in iOS 8.3 you can allow CarPlay without unlocking device, plug and play like android auto.

 

Does this work with the official 4000nex 1.08 firmware? That's really the only thing i'd like to have with CarPlay other than more compatible apps.

Share this post


Link to post
Share on other sites

I loaded the the 8100 firmware on my 8000, loaded up fine and booted up fine, i did notice the slight differences here an there, I couldn`t to get my Bluetooth work with my Lg G3, so I reloaded the 8000 firmware and it started to work again, I will reloaded the 8100 tomorrow and try again, I did notice it changed the device number and I have this in a 2011 f150 and I use the Idatalink maestroRR for my steering wheel controls and once I updated to the 8100 I lost the use of my steering controls and that could be that i need to flash the module as I have 8100 instead of the 8000, I will do more testing tomorrow :mrgreen:

Share this post


Link to post
Share on other sites

iOS 8.3 is introducing wireless CarPlay.  I'm hoping the 4000NEX will allow for that.

 

Someone else suggested this will require Wifi which is probably correct. I haven't see mapping or other apps working over bluetooth before.

Share this post


Link to post
Share on other sites

damn, well since everyone is having problems, even on identical models (8100 = 8000 part for part right????) im not sure what to take away from that. I'll try a few more things out but we may be SOL unless pioneer releases another FW for the X100 series that plays nicer. 

 

unless of course someone far more talented than I can open the .prj files, but I assume these are just packages for compiled code and won't make any sense regardless of how it is opened.

Share this post


Link to post
Share on other sites

I don't know how long some of you have been on this forum, but there may be interesting info here

 

http://avic411.com/index.php?/topic/38859-nex-runs-android-and-other-useless-info/?hl=+5000nex%20+firmware

 

and here

 

https://fail0verflow.com/blog/2014/enhancing-the-avic-5000nex.html

 

and part 2 of that

 

https://fail0verflow.com/blog/2014/enhancing-the-avic-5000nex-pt2.html

 

Maybe someone smarter than me can put all this together...

Share this post


Link to post
Share on other sites

 

Hey guys, so I have been working on flashing my NEX4000 to a NEX4100 and so far have had a lot of luck (images below) It seems everything is working except for the Pandora app. I want to do this the right way and not harm anyones devices. I am working very hard on understanding the 4000/4100 FW and as soon as I do I will also migrate to the 8000 and 6000 devices if I have people willing to test for me.

 

Below i have a donate button. This is not required but is certainly appreciated as my wife is pregnant and we are both starting out our careers so things are a little tight and spending time on this, while fun, does take away from other productive things I could be doing. Anything you feel comfortable with is more than appreciated to help!

 

 
Known Issues:
 
1. All BT audio (in and out) seems to not work.
2. Must reset SXM data after FW update to get SXM to work.
 
DOWNLOAD LINKS:
 

4000 (1.08) to 4100 (1.03)

http://www.filedropp...om/4000to4100_1

4100 (1.03) to 4000 (1.08)

http://www.filedropp...4100to4000test1

 

6000 (1.08) to 6100 (1.03)

http://www.filedropper.com/6000to6100

6100 (1.03) to 6000 (1.08)

http://www.filedropper.com/6100to6000

 

8000 (1.08) to 8100 (1.03)

http://www.filedropper.com/8000to8100

8100 (1.03) to 8000 (1.08)

http://www.filedropper.com/8100to8000

 

 

 

 
 

IMG_20150323_210118_zpsch7ybyyw.jpg

 

image%203_zpsszg9mhe5.jpg

 

image%202_zpsvnueg9sg.jpg

 

IMG_20150323_210104_zpsrzqweac5.jpg

 

image_zpssowzbgin.jpg

 

Let me know what you guys think!

 

 

hi covert_death, one question? are you sell your firm on eBay?, becouse i found in $40 bucks:

http://www.ebay.com/itm/271816740040?rmvSB=true

Share this post


Link to post
Share on other sites

I'll try a few more things out but we may be SOL unless pioneer releases another FW for the X100 series that plays nicer. 

 

I tried to find any evidence of people having BT problems with their new x100 units, but came up empty. I think BT works fine on the x100 units, so unfortunately I am not hopeful that the next x100 update would help us x000 owners :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×