Jump to content
AVIC411.com

Recommended Posts

 

*****iGO (Sort Of Easy) Map Updater*****

 

Hi all!

 

With the announcement of the map crack by asd255 http://avic411.com/index.php?/topic/81468-the-avic-development-mod/?p=337784 we needed a good way to actually update the maps!

 

With the help of various members (if you want to be named let me know), we have created a script that will install the needed iGO patch and install the maps that you have obtained.   

 

NOTE: This requires use of the perl command line on your computer to generate the required script.

 

 

Steps:

 

1. Download the attached MapPackage.zip

2. Unzip the file into its own folder. (For our purposes we will call it MapPackage)

3. Download the respective iGO Patch for your deck from http://avic411.com/index.php?/topic/81468-the-avic-development-mod/?p=337784

4. Extract the contents EXCEPT Copy_Script.sh into your MapPackage Folder.

5. Inside the updates folder in the MapPackage folder place all the map files you would like to add. It should like this (except different iGO patch files):

attachicon.gifScreen Shot 2016-01-20 at 2.40.09 PM.png

attachicon.gifScreen Shot 2016-01-20 at 2.40.17 PM.png

6. Open a Terminal/CommandPrompt Window

7. Cd to the MapPackage Folder

8. Execute perl MapCreator.pl  This will generate a script that will copy and set the right permissions on the map file you want to update.

9. Copy the contents of the MapPackage Folder to the root of a blank FAT32 USB Drive.

10. Put the usb stick in USB Port 1

11. Boot the deck

12. Navigate and select Write Programs Forcedly

13. Select Copy_Script

14. When it is done, remove the USB Stick and hit the middle center button.

15. Enjoy the new maps!!!

 

 

attachicon.gifMapPackage.zip

 

 

I followed exactly the procedure above to patch my F77DAB and update the latest maps using the goldenapple key (since the testmode_a.key didn't work with firmware 1.10) but it doesn't work. The device boots in the testmode but the content can't be copied. The output.txt file says the following:

/mnt/udisk/script.sh[10]: cat: <stdout>: Read-only file system Unable to chmod /system/lib/libigo_jni.so: Read-only file system

What am i doing wrong? Am i using the wrong testmode key?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×