Jump to content
AVIC411.com
joshaj84

X940bt Newbie

Recommended Posts

Can anyone please inform me with the correct steps to get my x940bt, version 4.00 to the newest latest and greatest maps/bt/updates??  Thanks

2015 (v6.0) is the latest and greatest. If you're willing to put forth some effort, you can get it at no cost by reading the thread 2015-avic-z120-map-update/  Hint - see post #84 to bypass the old info.

 

Otherwise:

http://www.navigation.com/is-bin/INTERSHOP.enfinity/WFS/Navteq-NavteqNorthAmerica-Site/en_US/-/USD/ViewStandardCatalog-Browse?CatalogCategoryID=JGQKCghBNfsAAAFCznk2EZA8&ShowAllProducts=YES

Share this post


Link to post
Share on other sites

Ron, do I need any updates before going straight to 6.0?  I saw that Pioneer has a unit update to 4.6, right now I am at 4.0.  I am just wanting to make sure I dont have to update in a step process.

Share this post


Link to post
Share on other sites

Ron, do I need any updates before going straight to 6.0?  I saw that Pioneer has a unit update to 4.6, right now I am at 4.0.  I am just wanting to make sure I dont have to update in a step process.

You can go directly to 6.0. However, if you use an iPhone with Lightning cable, install 4.6 first. It adds this support and AFAIK can't be added after installing 6.0. Pioneer really messed-up this Lightning support rollout.

 

Also, you should go to the Navigation.com web page (I linked above) and download the instructions and manual. There's some useful info there about the changes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×