Jump to content
AVIC411.com
majellin

Firmware update headache

Recommended Posts

New forum member here, just to clarify: despite the directions telling you to use USB1 a standard SD card inserted into the front of the unit can be used to update as well?  So if the unit is installed there's no need to uninstall it from the dash before updating?

Share this post


Link to post
Share on other sites

New forum member here, just to clarify: despite the directions telling you to use USB1 a standard SD card inserted into the front of the unit can be used to update as well?  So if the unit is installed there's no need to uninstall it from the dash before updating?

Ive used the sd card for updating. Try both and see what you like.

Share this post


Link to post
Share on other sites

I was able to successfully update my 8100 NEX via USB1 from firmware 1.05 to 1.09.. However, I tried updating my Bluetooth per the firmware directions and it's not working. I was on 03.41.10 and I get an ERROR in the process.    I used the exact same USB drive to do the firmware update and it doesn't work.  I tried to do the Bluetooth update via the SD card and same issue, it says it's updating don't turn off the engine and then I get an ERROR screen.  Does anybody have any idea what's going on before I call Pioneer?

Share this post


Link to post
Share on other sites

Hi all, Spec just referred me to this thread. I have just got a 2014 model F60DAB. It's got old firmware on. I am about to try doing the flash myself after reading this useful thread, thanks to all who contributed. Quick question - just in case it ends up taking me a while, is there a reason why upgrading the firmware will benefit me in some way, or is it just for security or to be "up to date"? I mean, will the unit run better, faster, more reliable, or anything else useful?

Once I have done that, I am hoping to find a way to update the maps without going through NaviExtras as their support wasted 4 hours of my time yesterday, they don't even make their website compatible for Safari browser, or their software compatible for mac computers, what a joke. I know macs are a minority, but its a big minority now, and they cut out 10% of the population when even the most basic software sellers can do a mac compatible version now for just about any program on the market! Not impressed with them at all, and the prices of their maps just had me bent double with laughter :D

Share this post


Link to post
Share on other sites

All I can say is wow, you would think for 1000$ or 750$ now , we would have never had to have any of these problems right? Well , I personally bought this deck and was happy with it, all of a sudden, o look an update, kool, lets do it...what is today? Yea my deck is still stuck reading the upload, still says fail, did everything that you all have up to the point I read this post...omg im going to do exactly what you said, nd im going to cross all fingers nd toes...I jus wanted to say good job and thanx for sharing !!! That was an awesome journey with a great ending , hope mine turns out the same!

 

Share this post


Link to post
Share on other sites

This is not "bad USB" cards this is fully due to Pioneer fragile update system and their failure to clarify on this issue or to fix bugs with their product.

I have tried half a dozen SD cards all different brands and several USB cards using Window 10, MacOS and Linux with no success.

If anyone here has enough computer experience to use dd to image a SD card or USB drive that does work for this it would be appreciated.  While I love the product I have avoided other Pioneer products because of this issue.  Unfortunately both BT and android auto are starting to have issues and I need to upgrade but I am tempted to just rip out the deck and change brands.

I am in this industry and reading FAT file systems or at least making a process that isn't this fragile is not a high bar and there are simple tools they could have used to package an update image if they cared.  I hate to be so negative about such an otherwise great product but don't let  Pioneer's development teams off the hook there, this common technical issue probably points to a severely broken culture and little desire to fix a long term pain point for customers.

This problem is not caused by various storage card/thumb drive vendors but is completely within Pioneer's development team's responsibility to fix.

Share this post


Link to post
Share on other sites

I'm having exactly the same error updating my AVIC6100-NEX. I have a bag of USBs that threw off the error. I have double checked it is trying USB1. I have edited my registry to avoid t he creation of the folder "System Volume Information" that normally happens with all any USB on a standard Windows machine. 

The Pioneer support person said basically, "I did it and it worked for me, your problem." I am stuck. I really want this update to 1.11 because it is supposed to help CarPlay. Any other ideas?

 

Share this post


Link to post
Share on other sites

You guys have me spooked.  This thread is exactly what's keeping me from updating from 1.03, lol to 1.11. 

I remember receiving an email from Pioneer on September 2017 advising to keep iOS 10.  I finally got my 8100NEX reinstalled recently and it's working ok.  I just know if I try to update it'll fail.  I think I successfully downloaded the update to an otherwise empty thumb drive & using iOS 12.1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×