Jump to content
AVIC411.com
Sign in to follow this  
gjljgj1@comcast.net

Avic X920BT upgraded to X940BT stuck at version 5.

Recommended Posts

Hi, 

I followed along with the instructions to update an X920 to an X940. I currently have a nicely updated unit operating on Firmware Version 5 and BT version 3.32. I would like to purchase the latest 2017 maps from Navigation.com but I'm reading that I need to get to firmware 5.1 before I install any additional updates. I can't seem to find a version 5.1 update anywhere. Can anyone point me in the right direction? 

Thanks,

 

Share this post


Link to post
Share on other sites
1 hour ago, gjljgj1@comcast.net said:

Hi, 

I followed along with the instructions to update an X920 to an X940. I currently have a nicely updated unit operating on Firmware Version 5 and BT version 3.32. I would like to purchase the latest 2017 maps from Navigation.com but I'm reading that I need to get to firmware 5.1 before I install any additional updates. I can't seem to find a version 5.1 update anywhere. Can anyone point me in the right direction? 

Thanks,

 

Keepin mind that you don't currently have a x-940, you have a X920 running v5.0 firmware.  In the 5.1 update it clearly says:

Capture.JPG

Share this post


Link to post
Share on other sites

I understand my 920 is running version 5, which I'm thinking is the firmware version of the 940. I completely understand hardware didn't get upgraded to a 940. Does that mean I don't need to go to 5.1 before ordering / installing the 2017 maps? I'm happy with the way the unit is working if it doesn't need anything more than to install the latest maps that's great, if it's going to lose some functionality then I'll install whatever it needs.   

Share this post


Link to post
Share on other sites
10 hours ago, gjljgj1@comcast.net said:

I understand my 920 is running version 5, which I'm thinking is the firmware version of the 940. I completely understand hardware didn't get upgraded to a 940. Does that mean I don't need to go to 5.1 before ordering / installing the 2017 maps? I'm happy with the way the unit is working if it doesn't need anything more than to install the latest maps that's great, if it's going to lose some functionality then I'll install whatever it needs.   

If it works now, it will work with 5.1. That was a patch to 5.0 to fix some issues with Apple Lighting support.

BTW, it is still on Pioneer USA's site: Software Downloads   Scroll down to X940 5.1 update. Read the instructions before installing.

Share this post


Link to post
Share on other sites

Thanks Ron, that worked like a charm I took it to 5.1 then to firmware 6. Next I'll order the 2017 maps not sure if I should order them for the 940 or the 920. I have another question that might be better suited to a new thread. Do the usb inputs on the X series have the ability to accept/ pass a digital audio signal directly to the onboard dac or is the usb input limited to analog only? I didn't see a thread asking that question but I'm thinking someone on this forum might be able to answer it.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×