Jump to content
AVIC411.com
MYQUE19

AVIC-x940bt Update issue

Recommended Posts

Long story short, I got this deck October of 2012 and it has been pretty good.  I registered it with pioneer and received the information on the updates 4.6 and 5.1

I had a previous conversation with them prior to the update and they were telling me about some units not having Navteq.  Needless to say I was confused reading which update I needed and did the 5.1 because it said if you don't have an iphone 5 you don't need it and I do have one so I thought that was the difference.. I tried the update and my radio is now useless!!  I tried removing battery cables to reset and nothing!! I removed fuses and nothing! the screen is black and wont do anything.  I called Pioneer and waited on hold for an hour to explain my issue and they said it was because I downloaded the wrong update, the 5.1 is for WHEN the new navteq update comes out.  I asked them if they are waiting for navteq why is it even available??  I have a hard time believing that installing the wrong update would render the radio powerless.  They said I was out of luck and they need to reflash firmware and I need to send it in for a charge. 

Please If there is anyone here who could help me start from scratch or has any advice,  Please let me know

Thanks

MYQUE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×