Jump to content
AVIC411.com
Sign in to follow this  
Benson X

AVH-P6800DVD + AVG-VDP1

Recommended Posts

Hey There, my name is Ben and I'm a "New Member" here with an Old-school head unit. 

Quick backstory:

I have a 2011 Toyota Tacoma with the JBL Premium Sound package and 6-Disc changer. I hate the JBL system; everything is controlled through the OEM amplifier and does not allow for upgraded speakers/Head Unit without replacing almost every component. So that's what I did - removed and replaced EVERYTHING. I have a massive CD collection, and I still prefer CDs over most any other medium (streaming, MP3, Aux. in etc.) so I wanted to keep the 6-CD changer. I found the AVH-P6800DVD was one of the last produced 6-CD head units, so that's what I started looking for. 

I found a used one, non-working, from a fellow off-road/Tacoma enthusiast that he was unable to sell. He offered to send it to me for free, I just paid the shipping. It arrived damaged (thanks USPS) with a broken LCD, damaged/cracked housing and bent armature/screws. I was little dismayed, but got to work finding all the parts I needed to repair it. I downloaded the Service Manual and Parts Diagrams, ordered a new LCD and rack gear, and was able to repair/replace all the components to get it working again. 

In order to get it connected and working with the Tacoma's wiring, I had to install a iDataLink Maestro RR to interface with the OEM harness. I also had to install/program a PAC SWI-X IR module in order to retain the steering wheel controls, since the AVH-P6800DVD does not have a dedicated 3.5mm SWC Remote Input. I also replaced ALL the stock JBL speakers, Amplifier and Subwoofer. All new components, all new wiring.

After wiring, programming and testing all the new components - the system sounds AMAZING!!! So much more control over the sound and EQ options. I am beyond happy (so far). I just had foot surgery, so it will be another 2 weeks before I can hobble out there to finish the install and button everything up. 

Here's what I installed (or am in the process of installing):

  • Pioneer AVH-P6800DVD
  • Pioneer AVG-VDP1 (EW model, converting to UC model)
  • Maestro RR
  • PAC SWI-X
  • Lightning Audio, 1200 watt, 5 ch. Amplifier
  • Pioneer TS-SW2502S4
  • Polk DB6501, Front
  • Alpine SPR-10TW 1" Type-R Tweeter, Front
  • Polk DB6502, Rear
  • Custom Sub Enclosure, behind the rear passenger fold-down seat
  • All new wiring all-around, RCAs, and 100-amp Breaker mounted on the battery cage

Things left to do:

  1. Convert the AVG-VDP1/EW model to the [UC] model.
    I purchased the unit from eBay from a seller in Italy. The model is listed as the EW spec (Europe West?), whereas I need UC spec (US & Canada?). After reviewing the Service Manual many times and studying the PCB diagrams - I found that the only difference between all the specs (EW, UC and ES) are the placements of the Resistors on the GDC PCB Board: Positions R1139 and R1140. The EW spec has the resistor connected to R1139, whereas the UC spec has that resistor connected to R1140 (ES spec has a resistor connected to BOTH positions). So, in theory, I just need to re-solder/swap the resistor's position on the GDC PCB.
    drviwXg2WAmUfj3C_ikZofQ9EWawQ_8ISwPMSGoM
    4SVr7unbkmWjBQ7miAqah5MotR2UgqaUeIn91Cab
  2. Service Test Mode Adjustments:
    I also noted in the AVG-VDP1's Service Manual that there is a "Service Test Mode" where I can change/adjust the GPS Positioning area. I was also concerned about this, since it is an EW model, if it will not properly display the Lat/Lon position in North America. I haven't yet tried, but I do not know how to enter the "Service Test Mode" on this unit.

    pVjMg2afuwLjxCcL1Sg_voL0H7a-EcFpX6Q62nTOSfG6s0Kp-F7de54fqPJNgggUspjSPt7dUy8E_Kex

    *I have not attempted to modify anything on the AVG-VDP1 (yet). I do not know the proper procedure to enter the "Service Test Mode" but I have a ticket in with Pioneer to get some help. Since this is a very old module - there is not a lot of information out there for it. I did not find any relevant info. about entering 'Service Test Mode'. 
     
  3. Wire-up the factory Reverse Camera to work with the AVH-P6800DVD.
    I need to splice the factory Video Output feed and run it to a separate RCA, connected to the "Reverse Camera Input" on the HU. I will also be trying to figure out to run an HDMI to Composite RCA connection to the addtl. Video Input on that same harness, so I can use it as an external display from my Samsung Note9 (though, I am not sure if this will work as I want it to). I will need to build my own 12-Pin RCA harness (CDE-8255) for the Video Input, since those specific harnesses are discontinued near-impossible to find now.  

 

Anyway , I just wanted to introduce myself and provide some initial info. about what I'm doing. I will likely be posting additional info. and/or questions in the various sub-forums on here. 

Please feel free to leave comments, ask questions, or provide any helpful resources/info. that may be assistance. Thanks!

 

 - Ben

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×