Jump to content

Recommended Posts

Some weeks ago I tried to update the firmware of my recently bought Pioneer AVH- X4800BS following the whole steps included in the guide.

Progress bar went from 0 to 100% in some minutes and then rebooted.

After turning back on, the screen just remained black. Buttons light up, screen also, but shows even no Pioneer logo.

I tried to access testmode by copying the testmode.key file into a formatted USB drive but it does not react to it.


I don't have the stock firmware, I would really appreciate anyone's advice/help... Please....


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...