Jump to content

AVIC 7100NEX dim screen at boot and then black

Recommended Posts

I've searched everywhere for solutions and tried what I found, but I still need some help and I'm hoping some of you can provide ideas. I'm very familiar with electronics, but not car audio. I have repaired modern TVs, vintage audio and pinball machines so nothing is outside of my comfort zone. I appreciate all of your replies in advance! Here is a summary of the problem followed by what I have tried. 


Once powered (ACC or ON) the LCD displays the NEX logo screen and then Pioneer Loading screen as expected, however it is very dim and does not always show up. After this normal cycle the screen goes 100% black and stays black, but on. The unit has a working touch screen and all internals work -- plays via Bluetooth and HD Radio just fine. Unfortunately its difficult to switch inputs because there is no screen. Buttons work, too. On a rare occasion a bump on the road brings the screen back. And then another bump turns if back off. This points me to a loose connection and this what I've tested. When the screen is dark and I press buttons out of annoyance I will occasionally get the screen to display the image by holding buttons, I believe it is the Map button. Unfortunately it is not all the time nor can I hold Map for 10 sec to override any backup camera as the manual states. So, I don't believe it is backup camera related.


Reset of the processor using a staple to depress the lower right button. No change. 

Disconnected power and ground for backup camera. No change. 

Re-soldered all wires of my Metra factory to Pioneer adapter harness No change. 

Removed front screen panel and reseated ribbon on the back but no change. Then replaced LCD with a known good panel (i have 2 of these) and reseated all connections on the board. No changes. 

Finally, I attempted to disassemble the entire unit to reseat cables inside the metal box, but I cannot get it apart. I can easily get the front panel off and then the top DVD drive off but this is where I end.


Looking for suggestions on where to start the next steps of troubleshooting. I have not tried to power it on the bench yet to see if there is low current and the screen is first to go. I can try this if warranted. Any tips on how to get the case to open? Seems like a puzzle that someone has solved. Could the internal SD be dead? Everything boots and works aside from the screen so I was thinking not. Another thing I have not tried is to disconnect reverse gear wire in case that is the culprit. 


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...