Jump to content
Sign in to follow this  

Can't modify setting on Avic-x930BT

Recommended Posts



I was googling around for troubleshooting and I just found this forum. I have installed headunits before but this is my first Pioneer Navigation unit. I was able to successfully install and powerup my new avic but I have an odd issue after I turn it on. I can't modify any of the setting for the unit (like when I click on settings the boxes are all faded grey and I can't push them).


I can modify the top 2 on right (AV settings and another one I can't remember). However, the bluetooth settings, navigation settings, security settings, etc...) are all greyed out and not usable. Also, the ilumination color of the buttons keeps changing (it goes through a rotation of colors while it on).


I tried doing a reset (hitting the mode button and back track buttons) and I was able to get to the intial setup again when it tells me to select the language. However, all the languages selections are grey on that and I can only select OK for a few questions and then I'm back to home screen again. Keep in mind, I can use the radio and and Ipod function as normal. It just seems like the headunit is locked in some way. I haven't put a password on it yet so it can't be that and I am running out of any ideas.


Has anyone ever experienced this before and if so can you tell me how to fix this? Thanks.

Share this post

Link to post
Share on other sites

wow, I just realized the parking break has to be on to be able to modify settings. Easier fix than I thought (but also a pain since my kenmore didn't do that). Thanks to anyone who tried to help.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this