Jump to content
AVIC411.com
Sign in to follow this  
Creepin_D

Satellite Radio signal strength issues

Recommended Posts

I have a Pioneer AVH-P2400BT deck with the GEX-P920XM add-on installed on my 2012 Xterra. I am having issues getting a good signal for my satellite radio. It works great in the city, but useless anywhere outside the city. My friends that own trucks that came with satellite radio have zero issues with signal strength anywhere on the island. I really do not know where to start troubleshooting my issue, can anyone give me some ideas? I cannot see it being the placement of my reciever because like I said before it works great in the city. Below is a pic of where I have the reciever placed.
 

20130701_091321.jpg

Share this post


Link to post
Share on other sites

I just installed the pioneer unit in my Chevy Avalanche and it works fine. It looks like to me that the structure on top of the Xterra is blocking the signal coming from the passengers side. In the manual it said to NOT place the antennae within 6 inches of any door or border and to place as flat as possible. You have all three "Do nots" in one application. I would place it on top of the vehicle out in the center of the roof and see if that does not fix your problem.   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×