Jump to content

F900BT bluetooth connection to iPhone 5 fails?

Recommended Posts

I recently got an iPhone 5 (not 5s) and switching from my old iPhone 4 should have been a breeze. However, when I try to pair the phone and my F900BT, it "hangs" while trying to connect.


If I try to connect from the Phone, I am asked to provide a PIN.  have tried several times. when I choose "111" as the radio suggests, it takes the proess a bit longer to fail, than if I choose a different PIN (e.g. "1234"). However with no success, no matter what


If I try to search from the radio, my iPhone shows up, and the radio begins pairing, asking me to tyoe in "1111" when prompted on the iPhone.. My iPhone prompts me for a PIN (so I know that Bluetooth is working), but after a while, the radio gives up and fails.


I have tried upgrading the newest firmware to my F900BT and my bluetooth firmware is HW100-SW290 (which I believe is the newest version for European radios? (I found an update to version HW100-SW330, but that only applies to Blackberrys?)

My iPhoneis running the newest iOS 7.1.1

(I know that my new iPhone has Bluetooth 4.0, but that should be backwards compatible.)



Has anyone had is problem and do you know of any solution?


Best regards,



Link to post
Share on other sites

I can't really answer your question, but I would expect it to work. All phones are compatible with the old BT (as far as I know). My Nexus 5 connects fine (not sure which BT version, not the bb one).


The F900bt is a bit of a weird device however, because a while ago my phone stopped connecting to it (after months of working fine). I didn't change anything in the settings of any device, and they showed in both as paired device. When I tried pairing them again it also failed a few times (nothing really happened after entering the pin). I think what did the trick in the end was making sure that in both devices they weren't showing as paired devices (so delete them), turning BT a few times on and off, and suddenly they connected again, and have been for weeks.


So don't give up ;)

Link to post
Share on other sites

Thanks Lydus. But I've tried perhaps 20 times and I have deleted the unsuccesfull pairing everytime, with no luck. I have also written to Pioneer Support, so far without getting an answer.


I will keep on trying regularly, whenever I enter my car, but have reverted back to using my good ol' Apple iPhone Bluetooth Headset, which still works (including Siri commands)!

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

@petervandamned: My iPhone is also a 5 (not s or c) and I have (a part from older maps) downloaded the newest firmware from Pioneers website (EU versions since I live in Denmark) but still no luck - and no reply from Pioneer yet. Did you get firmware from AVIC411's website? If you have a link, please let me know. A longer discussion on Apples forums would have me know that it might be a faulty implementation from Pioneers side, with regards to backwards compatibility of some standards, but they fling mud both ways, so I'm a bit lost.

@Elec91: Tres bien, but that helps in absolutely no way, as I will never get a BlackBerry...

Link to post
Share on other sites

I experienced a similar problem connecting my iPhone 5 to my plantronics legend headset. It worked well with the 4s but it would constantly drop connection with the i5.

All I needed to do was upgrade the BT Software and all was good. Now it runs just like the 4s.

If you want people that know what they do, plantronics are meant to be the best at what they do apparently. I would have guessed as far that pioneer wouldn't have a clue.

I'll try to find the file and upload it ASAP if that might work

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...