Jump to content
AVIC411.com
forcefedcobra

I think I am in trouble.............

Recommended Posts

Well after taking a look at my metra wiring harness for my 03 cobra D3 install I decided it was better to leave it up to the pro's. I work a crazy job so I never really know when I will have time off...........So today I take it to one of the two install shops in town and they squeeze my car in among all their other work.

 

I had already purchased the metra wiring harness and the metra install kit so everything was in the box and ready to go..........I get a call saying they cant install the unit because it is a double din.............I said okay with a puzzled hint in my voice and the guy says the install kit isnt the correct one because my unit is a double din. I laughed and said well it is the same kit you were going to order for me and it just so happens to be an iso mount already installed on the deck so it just needs wired up and slid into place......He said he would go look but the tech said it was wrong and would call back. So far no phone call so I hope they get the dang thing put in and I can get my car before the end of the day because I wont be happy if I have to drive it around without my new radio and I am not leaving it there over the 4th when they are closed.

Share this post


Link to post
Share on other sites

they got everything done but didnt connect my gps atenna so I had to route that myself.

 

They did ground the parking brake wire with the ground though and now my system says there is a bad connection on the parking brake. Just need to get in there and ground that mute wire for the bypass.

Share this post


Link to post
Share on other sites

what kind of assholes did you bring it to that they didnt even hook up your antenna? you paid them to install a navigation system, how could they leave out such a main component?

Share this post


Link to post
Share on other sites

Well I got my backgrounds put on and everything else is working.

 

I'll go back and ground the mute wire after I check the vss wire and also tap into the dimmer switch for night mode. I am tired of taking all the trim on and off..........

 

Well needless to say they are arsholes that I will never take anything back to. In the past they were pretty good working on other cars of mine but now both shops in town have burned me with shady work and will never get another dime of my money.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×