Jump to content
AVIC411.com
MusclebobBuffpants

Screwed up updating firmware, won't read sd card to try again

Recommended Posts

I have an F7010BT.

 

The other day, the unit would turn on with the car, but would only go to the splash screen for about 10 seconds then shut off. I could still hear it runing though.

 

So, I went online and discovered the firmware for 2.008. I read that a firmware update could fix my problem.

 

I downloaded the file, but did not unzip it like an idiot. Went through the update process, and suspected all was good. However, I can only access one of the settings folders, and basically nothing else. It also reboots every few minutes.

 

I tried updating the firmware again with the file unzipped (2.008 and 2.006), but it won't recognize the sd card. I get the error message that I attatched, but it freezes when I click on it.

 

Any ideas? Will the "Basic Reboot Loop Fix" sticky help me out?

 

 

post-127128-0-40367700-1417663155_thumb.jpg

Share this post


Link to post
Share on other sites

Hello,

 

welcome to the F series reboot club... :wink:

Yes it seems like you have had a corrupt file on the Avic and first signs are the reboot loop.

 

"Basic reboot fix" is a way to fix the unit.

 

Download the backup files and testmode. The files are for a American/Canadian version of the Avic.

If you are in Europe or Russia you need different files.

 

Good luck.

 

And to make you feel better. (Not unzipping the files is not the cause of failing) If the corruption kicks in,

a firmware update alone rarely fixes it.

Share this post


Link to post
Share on other sites

Yes sorry forgot to mention,

 

Many file have to be scavanged,

yes the PirateBay's file is the file you need. It's huge but very complete,

I'll put up my pc so you have an extra seeder ;-)

 

Testmode (v2.3) is available on the forum. Or I can send it to you if you want.

it's only 700 kb. But it's also included in the fix-files.

Share this post


Link to post
Share on other sites

Yes it does,

 

Follow the steps.

Don't rush things and let us know how it went.

 

(Please make sure there is no power-interuption during the copy process.

 you can set the unit up for copy and drive, or keep the engine running or charger on the battery)

Share this post


Link to post
Share on other sites

Hi,

 

I was affraid it wouldn't be sufficient, simply said if any of the files go bad in avic units they start the reboot-loop.

(Why this thing just doesn't say... file x cannot be red..) Instead if the unit is unhappy it restarts. 

Wich is pointless as it doesn't fix anything and it doesn't give any clue to where to look.

 

Now the reason the easy reboot-fix exists is because some file are prone of going bad. GPS files are alway open

so they have a bigger chance of getting corrupt then a map file. Overcopy-ing the files with known good ones,

wich you did has a better change of fixing the problem, yet a specific part of the avic cannot be viewed and that's

the WinCE Image part. 

 

Update that part is more complicated, i'll try to give you some links but I am at work now so cannot do it from here.

try to search the forum and there are many fix advices, the only one you should NOT do unless all other are

exhausted it, format MBR. It whipes your device serial-number.

Share this post


Link to post
Share on other sites
I did not make this help it's very similar to the (major-Fix section) but modified on one specific point,

I left out the part to update the SDMLC (that is the last-resort plan).

 

Be aware it's a long session to get it all done. For my own unit I took it out of the car and connected it to a 12v power supply.

But that's up to you. I still assume you are trying to fix a American/Canadian unit otherwise you don't have the correct files.

 

 

Part I (Download)

1) A torrent full of the fix-files. (you already have them)

 

Part II - UPDATING WinCe

For this I am going to refer to my torrent file so I hope you downloaded it 

and use the file structure from with in. 

 

1)Format your SD card or Cards Fat32

 

2)Add WinCe files to your SD card

a) go to Avic Provlem Solver Files>Wince Copies>From 2.0

b ) Copy these two files (Winceimg.Bin and Winceimg.cks)

c) Paste these to the route of your SD card

d) Eject SD card

 

3)Go out to your car. Start up the AVIC then try to enter Service Mode

a) Press Reset, EJECT, MAP, MENU all at the same time

b ) Let go of Reset but continue to hold the rest

c) When you hear your speakers make a small pop sound let go of EJECT but continue to hold MAP and MENU

d) A blue screen will appear that says press reset DO NOT press reset

c) enter this code in, as you do * will apear at the bottom of the screen for each button pushed. on the nob Push

UP UP DOWN MENU LEFT RIGHT

d) This enters you in SERVICE MODE

 

4) Do not mess around in here, this is what leads to bricking of uinits! Once in here press the nob in for Windows Upgrade

 

5) insert SD card in the slot and then click the first Option Upgrade from SD/USB (formated)

 

6) You will see a Blue Screen and it will be uploading the WINCEIMAGES once it is complete it will tell you to restart. Shut off your car.

 

It will be good to have 2 SD cards here:

(1). The smaller one for the firmware update. (512mb)

(2). The bigger card should be for backup files. (2GB)

 

Part III - Firmware Update. (Card #1)

1) SD Card 1 (if this is the same one you used for the WinCe flash you need to Reformat it) Update Files

a) go to Avic Problem Solver Files > Updates > F-Series Firmware Update

b ) Copy the folder LPUE080

c) Paste this folder into your SD card

 


Part IV Restoring Backup. (Card2 #)

1) Format the larger (2gb or bigger SD card)

2) Navigate on pc, to Avic Problem Solver Files > Copy of My Flash Disk > 2.0 F700 then Copy the folder F700

3) Paste This on SD card

4) Also need add testmode folder from Testmode_V2.3 like you did before

5) Bring out to car


 

Go to you're car.

 

Step 1 Doing the firmware-update

a) Put SD card #1 (the one with LPUE080 folder on it) into Avic

b ) Start car and let the firmware update ruin... this takes a while sometimes.

c) once its finished shut off car and take SD card #1 out

 

Step 2 Doing the backup restore.

a) put SD card #2 into car

b ) turn car on

c) wait for it to go to what looks like windows 95

d) Once in windows mode you will go to Explorer under Start/Programs/Explorer

e) Go to your storage Card find your folder you pasted from Part IV labeled f700 and open it.

f) Click Edit/Select All 

g) click Edit/ Copy Copy

h) Open a second explorer window, Start/Programs/Explorer

i) Double click on "MY FLASH DRIVE" 

j) click on EDIT/PASTE even if it gives you an error message saying there is not enough room press ok. It will begin to copy files, make sure if you are ever asked if you want to copy over a file you click YES ALL.

k) This may take about 15 minutes to complete.

 

15)Once done close out all the folders and restart your unit 

   (either hold the reset button in, use the restart program, or shut off car and turn it back on.

 

Step VI - Make sure it works

You may need to wait about a minute for it to load because it is going to act like it is its first time ever loading if for some reason it does not load here. Reload a firmware update and you should be back in business. If it does load but cant find your GPS location, drive around a bit or go to an open parking lot and shut off your car then turn it back on sit for a few minutes it should find it.

 

Optional Steop VII - Upgrade unit

At this point I would update your unit especially if you had been running 3.0 + you have paid for this already and have rights to it. All the files you need to do this are also in this torrent... the short of it is you need to flash the appropriate wince files (the winceimage .CKS and .BIN ) from service mode. Then you need to copy the appropriate corisponding backup to your avic. In these files you have several options for US avics... for Euro avics you can upgrade to 3.0 via pioneers update. 

 

Again I don't take credit for this great manual that helped me. Good luck.

Share this post


Link to post
Share on other sites

Hey, man. I finally got around to trying that last solution. It didn't work though. I'm sure I followed everything correctly.

 

At the end where it says "if it does not load, then reload a firmware update", it did not load. So, I reformatted a card, put the firmware on it, tried it again, but no good. I'm back to where I was.

 

Should I try all of that again? Is the "last resort plan" difficult? I don't think I care about the serial number lol.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×