Jump to content


Recommended Posts

I discovered that my F920BT worked perfectly and didn't restart (reboot) when I started the car. 

It never had updated the firmware, but today I updated the firmware to the latest version (2.00300) published by Pioneer.

My surprise was that after the firmware update my AVIC F520BT restarts (reboot) when I turn on my car.

How can I do a downgrade to know if the error is the firmware ????


Has someone had the same error ????



Link to post
Share on other sites

Is it possible you let your battery run-down some during the install? 


My Z110BT used to always reboot when it was playing as I restarted the engine. Even with a new OEM factory battery. Last month I needed a new battery again and I bought an AGM with 900 CCA. Now it always keeps playing when restarting.

So maybe your battery's residual power drained just enough (during f/w installation) to cause a reboot when the volts dropped while cranking. Try putting the car on a charger/maintainer overnight, or taking an hour-long drive. It takes the car's alternator quite a while to fully charge a battery. 


BTW, I really doubt this is a software issue.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...