Jump to content
Sign in to follow this  

End of my last wits,, need help with AVIC X series + XM tuner please

Recommended Posts

Hey guys, new here but I am truthfully hoping someone can help me because after 7 years with this nav unit, I am at the end of my rope with it.


Not even going to get into the problems I had in the past with it, just the current problem.


So I got an older but working and nearly new XM reciever which is the Onyx XM XDNX1 in a regular dock and coming out of the dock is the antenna, the power and the signal. The signal can either be a headphone to headphone sizing or the headphone to RCA (red/white) and I have both of those cords.


The NAV is the AVIC X710BT and it has the apparent capability to do XM / Sirius radio and HD radio etc etc. In the manual it talks ALL ABOUT how to operate the XM or Sirius once they are linked or run together but it doesn't say ANYTHING about how to link them or run them together. I have tried every way I can see and none of them works.


I tried going into the audio inputs with the red / white cord, I tried going into the AUX in the front (which has never worked for any reason for anything and seems like just a useless input because it's never worked for anything.). I have tried plugging into some random headphone looking jack in the back of the unit. Nothing works. I am assuming that like the iPod, I need some sort of a harness or special cord to link the XM to the AVIC but I can't find mention of the cord or harness anywhere or which one I would need.


Someone please help a guy out here, I am going nuts without tunes and my iPod broke.

Share this post

Link to post
Share on other sites

I am not sure if this will help or you tried this already but you need to go to menu or setting what ever on your unit and go to system and look for av1 av2 put them both on you may have like

ext, for external, and they have video, ipod, and I think theres one other setting you can do then try going thur  the front 3.5mm port again and mess around with them

settings. Also if you do a hard reset hold it in for 10 seconds or more, then there should be a setting in the menu or setting section called in initial settings and you get 

more ones only at the hard or full reset setting once only get it another words at the reset.. Hope this helped.. :):);):( 




Hope this helped I love to help



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this