Jump to content
AVIC411.com
Gostek

AVIC F960DAB - Firmware problem ?

Recommended Posts

Hi guys, it is my first post in here. 

 

I am an electronics engineer, working in field for about 25 years now.

 

 

I recently obtained a AVIC F960DAB with problem, but i don't know it's history.

Unit once powered displays the following screen:

 

 

post-145893-0-19559600-1503408127_thumb.jpg
 
then:
 
post-145893-0-39342300-1503408168_thumb.jpg
 
 
What I tried to fix it:
  1. Download latest firmware from Pioneer website, extract to SD card - no change.
  2. Go to the test mode mode using testmode_a.key (with content from https://github.com/bassrock/AVIC-NEX/blob/master/README.md)
  • only one key worked for me - 007PRODUCT003ALL00833333333007PRODUCT0082013010100820201230000, allowed me to start the unit and go to the FW information screen (see below) and update screen, but it was unable to finish update procedure.
  • other keys did not work (I just simply copied content from website to the testmode_a.key file
  • I also tried to go to the debug screen (as the home screen was available with above key), but it did not accept password (DEVELOPDBG ON).

 

post-145893-0-13210500-1503408206_thumb.jpg

 

 

What else I can do to make it work ?

(I am able to use console)

 

Best Regards

 

 

post-145893-0-19559600-1503408127_thumb.jpg

post-145893-0-39342300-1503408168_thumb.jpg

post-145893-0-13210500-1503408206_thumb.jpg

Share this post


Link to post
Share on other sites

Hey Gostek,

 

My unit was exhibiting similar behavior. I follows steps 1, 2 and 3 on this thread, once I completed the Copy Script method on step 3, my unit was able to boot into its operating system instead of booting into the "Reading..." and "Update Failed!" screen as your first two screenshots show.

 

I'm still unable to upgrade the firmware on my unit but it got it back to a functional state.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×