Jump to content

AVH-4800BS - Odd behavior and unresponsive

Recommended Posts

I'm not sure if this happened as soon as I started my car as I was rushing, but at least a couple minutes in at the first red light, I notice the faceplate on my unit was completely flat in the cd insert/eject position. The screen was on, but blank except for the symbol that is shown on the tilt adjust screen in the center. I never listen to CD's or play DVD's so maybe this is normal behavior when the scree.n is in this position? If it's relevant, I have it set to tilt (max setting) when the unit powers on. I tried pressing the front hard keys to get it back to normal operating mode. Probably more relevant than my tilt setting is that my front buttons don't work as they should. I purchased the unit used and none of them worked. I took the unit apart and found the circuit board had been fried, I forget which area, but just a small spot. I did what I could to clean up the area and make the connection complete again (after attempting to swap the board out with one from an AVH-4400BHS ha). Some buttons worked but for random operations, the rest were still dead. I was able to eject CDs and skip to the next track.

It didn't go back into normal operating mode instead computer BIOS type screen showed up saying something about an update, or software install, something like that. I was driving and with the sun it was hard to see at that angle. I remember words at the top being in red letters with blue dashes before and after the sentence like a title. Or blue letters with red dashes.. lol. It said some install or update was in progress and not to power down the unit or disconnect the usb. I do use a usb thumb drive to play music, it's been the same drive since I got the unit, and it hasn't been disconnected in months. After 30 seconds, */- 15-30 seconds the screen changes to an update failed screen, saying a file cannot be found, or install invalid... some sort of failure message and to try again or reconnect something.. basically you failed, but you can try again. I tried pressing buttons again and it went back to the blank screen with the CD symbol in the middle and then back to the software thing, then the fail screen. It did this in a loop until I turned my car off when I got to work. I turned the car off on the cd symbol screen and not the update one. The screen stayed completely open. Usually after I turn the car off it waits a second and then closes. When I left work and turned the car back on the unit didn't power on or show any signs of life. It's been completely dark since, chillin perpendicular to the unit.

Help, please.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...