Jump to content

Avic-7000nex stuck - update failed!

Recommended Posts

Avic-7000Nex seems to have bricked. When i boot the system, it shows "Reading Please wait for while" and then shows the update failed! screen (photo attached). I tried updating the firmware, but it always shows updating 1.03 to 1.03 regardless of what version of firmware is on the usb drive. I already tried using different usb flash drives (about 6~7). The usb flash drives is inserted in usb1 slot. I can see the device reading the data from the usb drive, but for some reason doesn't detect the new firmware. Each time i put in the usb drive, it takes a while to read the data on the drive, then shows updating 1.03 to 1.03, progress shows -1 at it exits to the update failed screen. I looked through several forums, but i can't seem to find anything to fix my screen.

Any help would be deeply appreciated.


Link to post
Share on other sites
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...