Jump to content


Photo

Avic Z2- Sirius module not responding & no function


  • Please log in to reply
4 replies to this topic

#1 Sal

Sal
  • Members
  • 2 posts

Posted 16 November 2011 - 01:14 AM

Hey all new to the site but used it once for the wire mod on the DVD/NAV setup.

I have been running the Sirius module in my Avic Z2 for several years without any problems. The other day it just stopped functioning, heres whats going on:

-Screen reads "SIRIUS" only, nothing else. It flashes and scrolls across the bar
-No sound
-None of the functions work, channels, band etc
-Originally was stuck to one channel- Until I uplugged the battery
-Now is stuck on channel 000
-Cannot change channels
-No help from Sirius
-No help from Pioneer
-All other functions on head unit work fine

I unplugged the battery in attempt to reset the system. When I started it back up it just reset to channel 000, but has the same problem- no sound/signal and none of the functions work

I tryed resetting the head unit with that tiny button near the vol control, no difference.

I pulled the Sirius module and unplugged all the connections, restarted with no difference.

I checked the connection in back of the head unit, all wires and connections appear to be ok.

Any advice or help is appreciated! thanks -Sal

#2 chodelip

chodelip
  • Members
  • 5 posts
  • LocationTulsa, OK

Posted 26 January 2012 - 07:31 AM

Exact same thing happened to me. I did everything you stated as well and even did the refresh signal from Sirius. My satellite radio was working great for 3 weeks then locked up just like you said. Tried all that and still nothing. I've only had it 3 weeks too! I was driving down the road when everything went silent. Tried to change channels and nothing would work. Everything else operates great; FM, DVD, USB, SD, iPod. Sirius is frozen.

I did the whole checklist like you did and still nothing. So I ripped it out and sent it back to Crutchfield for a return. All the reviews I've seen on the CD-SB10 said that it freezes up and doesn't respond to anything. I just ordered the GEX-P920XM and will install that when it gets delivered. I've had Sirius forever and now will have to switch over to XM. That's fine with me since the music, news, and comedy channels are the exact same. I never listened to Howard Stern but I will miss listening to NFL games while I'm driving if they're on.

My advice would be to drop the Sirius tuner and go with the XM. You could pay a few dollars extra for Howard Stern and NFL if you wanted to. From what I've read, Pioneer makes the XM tuner but not the Sirius tuner, which is probably why the Sirius tuner has such horrible ratings and issues with locking up. Wish I did some research beforehand but whatever. I'm pissed that I'm returning a new product after 3 weeks but at least it's still under the return warranty. I guess it's better now than done the road a couple months.

#3 GregD

GregD
  • Members
  • 2 posts
  • LocationSan Antonio, TX

Posted 30 January 2012 - 12:17 AM

Sal, did you ever find a solution to your problem? I'm having the same issue

#4 chodelip

chodelip
  • Members
  • 5 posts
  • LocationTulsa, OK

Posted 30 January 2012 - 01:23 AM

Try gounding it to the chasis. Check the fuses. Reset all of it. Check the cables and make sure you have them connected right. I've read this is a very common issue that often results in having to exchange it for another one.

#5 mdyod

mdyod

    Member

  • Members
  • 60 posts
  • LocationWM - Louisiana

Posted 03 September 2013 - 12:22 AM

anyone ever find a solution to this problem? I have a Z1 with the sirus module - it flashes "updating" but will not play music or respond to any commands ...


"Live Long And Perspire"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users