Jump to content


Photo

Canadian 2012 Subaru Legacy Factory X9310BT NAV Bypass


  • Please log in to reply
2 replies to this topic

#1 fugue

fugue
  • Members
  • 3 posts

Posted 11 May 2016 - 05:16 PM

After alot of reading, I found a very simple solution to the NAV bypass on my 2012 Subaru Legacy 3.6R  factory installed X9310BT (which I just bought).  The Canadian cars are wired differently-there is no white RCA harness plugged into the unit.  There is a similar white Subaru harness that connects into the black harness which plugs into the back of the unit.

 

There is an unused purple wire with a button connector on the end that is in the black harness.  I simply removed that and used it as a jumper cable from the top (2nd from Left) pin on the unit's white RCA socket and grounded it to the unit chassis.  No VSS or brake cable grounding needed.  Everything works like a charm!  Also, I didn't have to buy a spare RCA harness!

 

Pic below looking from the rear of the unit:

 

 

Attached File  DSC_0076.JPG   131.58KB   7 downloads

 

 



#2 ac146

ac146

    Member

  • Members
  • 49 posts
  • LocationNova Scotia, Canada

Posted 13 May 2016 - 12:24 AM

Hi fugue!

I have a 2012 Subaru Legacy as well (2.5 Limited though) and the x9310 as well. I was going to take to a car stereo shop this summer to get the bypass done. i might try this!! Cool idea.

#3 Omineca

Omineca
  • Members
  • 3 posts

Posted 04 September 2016 - 07:29 PM

This worked and was so easy. Thanks!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users