Jump to content
AVIC411.com
jelld1

F150 Steering Wheel Controls

Recommended Posts

I have a 2010 F150.  I had a AVIC-8200 NEX installed and the Sync and telephone buttons on the steering wheel do not work.  Along with the Pioneer an FO1 and RR were installed to retain steering wheel controls.  Could it be a bad Sync module?

Share this post


Link to post
Share on other sites

your not the only person on the forum with steering code issues, have you tried updating the firmware on the headunit and then trying again, and using the proper idatalink adaptor to retain the steering controls, is the installer knows whats he doing? you could call pioneer, but they would definately want to know what module you installed to retain the steering controls and/if it has the latest firmware itself etc, so you'd need to know that. the installer supposed to make sure that works

Share this post


Link to post
Share on other sites

This may not answer your question, but I wanted to at least add it to the discussion.   I have a 2008 F150 and I have the AVH-4200NEX unit (very similar to the 8200).  I purchased, and installed myself, a steering wheel control module from Axxess (model: ASWC-1).  It works perfectly.   The ASWC-1 was very easy to install but I did have one issue that might be of help.

 

First, all items were ordered from Crutchfield, including a wiring harness.  It should be noted that the wiring harness does not have an actual wire and pin at slot 18.  Looking at a F150 wiring diagram of the car audio wiring harness one can see that pin 18 is steering wheel control signal return.  The ASWC-1 instructions state that on the wiring harness this slot, interfacing with Pin 18, should be connected to chassis ground.  I admit, I am no electronics expert, so I did the only thing I knew to do...and a wiring harness cardinal sin:  I left about 3 inches on the OEM side of the OEM connector, and I cut the wire leading to Pin 18 and I soldered/heat shrink a new black wire to it and took it to a common ground to direct bare metal.

 

The other wires that needed to be connected (were just as stated in the instructions):

1.  Green/white on the AWSC-1 to the green on the 4200nex

2.  Black to common chassis ground

3.  Red to 12v accessory.

4.  3.5 mm male to 3.5 mm female on the back of the 4200nex labeled W/R

 

The hardest part of the install was the step in the process where the installer must hit the RESET button.  Weird but true.  You have to stick a pin other tool into a hole in the module.  I followed the instructions and NOTHING happened according to plan.  Turns out, my pin/tool I was using was not actually reaching far enough into the module to actually achieve the reset.  I changed to a micro screwdriver (just a longer tool) and it worked first time.  DUH!

 

Once the ASWC-1 went through the series of automatic LED flashes, as per instructions, the controls worked with no further action by me.

 

For $27.00, this unit is easy and worth it.  I recommend it and....it allows some custom programming that I have not yet attempted (just got this installed last weekend)

 

https://www.crutchfield.com/p_120ASWC1/Axxess-ASWC-1-Steering-Wheel-Control-Adapter.html?tp=3405

 

I hope that something in the above might help you or a future reader.

 

Thanks,

Kevin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×