Jump to content
AVIC411.com
NothingCreative

X930BT Upgrade uCom Issue

Recommended Posts

Hello,

 

I'm hoping I can get an answer here after hours of researching these forums. I have an X930BT that I upgraded from 3.0 to 5.0 tonight, which I read means that it is now an X940BT for all intents and purposes. I did this because my understanding is that you need to install the 5.1 update in order to have the Pioneer Lightning cable work, I couldn't just upgrade straight to 6.0 because I guess it doesn't include uCom updates, which is the whole point of the 5.1 update. I've downloaded and redownloaded the 5.1 update from Pioneer's website and every time I try to update the uCom version, it lists ------ for the version on the SD card. According to the PDF for the update, this indicates a corrupt download. I've also tried reformatting my SD card several times, FAT32 with 16K clusters. If I boot up without the SD card, the deck works normally, and the Application Version is listed as 5.1.

 

Since there's no going back once I upgrade to 6.0, I want to make sure of what the significance of this is. I'm guessing that I still need to find a way to successfully install the uCom update. Just double checking if anyone has any insight before I proceed. Thanks for any help you all can provide!

Share this post


Link to post
Share on other sites

On the uCom Forced Write screen, what version does it show under uCom? Oddly, the instructions don't ever say to do anything other than check that version 8.05 is installed.

 

BTW, I have never been able to get forced write to read from an SD. But I don't use a Lightning cable for my old iTouch.

Share this post


Link to post
Share on other sites

It currently has 8.01 on it. I can't find a lot of information on why the files aren't recognized, or if they're even necessary once the update gets performed. But it seems like this is the most important part of the update since it's the only way to get it.

Share this post


Link to post
Share on other sites

It currently has 8.01 on it. I can't find a lot of information on why the files aren't recognized, or if they're even necessary once the update gets performed. But it seems like this is the most important part of the update since it's the only way to get it.

Yes, I believe it is necessary to support Lightning cables. uCom is the microcomputer software. I believe that would include low level drivers. However, as I said, I never manually updated my unit. After installing 6.0, I now have uCom v8.12. So I assume that the v6 update loaded it.

 

I'll let you decide whether that means it is safe to go ahead. Maybe someone else has some experience with this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×