Jump to content


Photo

X930BT Upgrade uCom Issue


  • Please log in to reply
4 replies to this topic

#1 NothingCreative

NothingCreative
  • Members
  • 3 posts

Posted 18 May 2017 - 05:27 AM

Hello,

 

I'm hoping I can get an answer here after hours of researching these forums. I have an X930BT that I upgraded from 3.0 to 5.0 tonight, which I read means that it is now an X940BT for all intents and purposes. I did this because my understanding is that you need to install the 5.1 update in order to have the Pioneer Lightning cable work, I couldn't just upgrade straight to 6.0 because I guess it doesn't include uCom updates, which is the whole point of the 5.1 update. I've downloaded and redownloaded the 5.1 update from Pioneer's website and every time I try to update the uCom version, it lists ------ for the version on the SD card. According to the PDF for the update, this indicates a corrupt download. I've also tried reformatting my SD card several times, FAT32 with 16K clusters. If I boot up without the SD card, the deck works normally, and the Application Version is listed as 5.1.

 

Since there's no going back once I upgrade to 6.0, I want to make sure of what the significance of this is. I'm guessing that I still need to find a way to successfully install the uCom update. Just double checking if anyone has any insight before I proceed. Thanks for any help you all can provide!



#2 RonS

RonS

    Established Member

  • Moderators
  • 1387 posts
  • LocationBelleair Beach, Florida

Posted 18 May 2017 - 12:43 PM

On the uCom Forced Write screen, what version does it show under uCom? Oddly, the instructions don't ever say to do anything other than check that version 8.05 is installed.

 

BTW, I have never been able to get forced write to read from an SD. But I don't use a Lightning cable for my old iTouch.



#3 NothingCreative

NothingCreative
  • Members
  • 3 posts

Posted 18 May 2017 - 02:04 PM

It currently has 8.01 on it. I can't find a lot of information on why the files aren't recognized, or if they're even necessary once the update gets performed. But it seems like this is the most important part of the update since it's the only way to get it.

#4 RonS

RonS

    Established Member

  • Moderators
  • 1387 posts
  • LocationBelleair Beach, Florida

Posted 18 May 2017 - 03:19 PM

It currently has 8.01 on it. I can't find a lot of information on why the files aren't recognized, or if they're even necessary once the update gets performed. But it seems like this is the most important part of the update since it's the only way to get it.

Yes, I believe it is necessary to support Lightning cables. uCom is the microcomputer software. I believe that would include low level drivers. However, as I said, I never manually updated my unit. After installing 6.0, I now have uCom v8.12. So I assume that the v6 update loaded it.

 

I'll let you decide whether that means it is safe to go ahead. Maybe someone else has some experience with this.



#5 NothingCreative

NothingCreative
  • Members
  • 3 posts

Posted 18 May 2017 - 04:46 PM

I guess I'll roll the dice, worst case scenario is that I'm stuck using my phone via Bluetooth and I'll have to get a 30-pin iPod, iPhone or iPad to stick in the glovebox wired. Thanks for your help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users