Jump to content

AVH-4000NEX stuck in firmware udpate v1.20 loop

Recommended Posts

Hi guys,

I have an AVH-4000NEX V1.11 and trying to update to LATEST version V1.20 but the update keeps failing at 66% each time.

I'm using SDHC San Disk card and used the same card  in the past to update from  1.21 to 1.11.

I tried a different approach by using a USB key plugged in port usb 1 but it's not picking it as the FW update source even when SD card is empty.

Any known fix for this. I'm desperate about Pioneer.








Link to post
Share on other sites

Ok guys. I hope this can help some of you in the same situation.

 I made the unit out of the coma.

I was actually on v1.11 and i downloaded the exact same firmware.

The unit showed 1.11 > 1.11 which is weird updating to the same version but it worked. The update finished till 100% and the unit booted normally.

Now i'll leave it alone no updates in the future .... thank you Pioneer for the shitty updates.


Link to post
Share on other sites
  • 1 year later...

I had the exact same problem today. Tried to update firmware on my Avh-4000nex from 1.14 -> 1.20.

the update stopped at exactly 66%. This happened from both USB drive and SD card.

recovered by rebooting with 1.14 files on thumb drive when rebooting.

anyone successfully update this unit to 1.20 firmware?

I also tried updating from 1.14 -> 1.15 and had exact same result. The update crashed at 66% complete.


Link to post
Share on other sites
  • 2 years later...

I updated successfully to version 1.20 after many attempts. Once updated I discovered I couldn’t access Bluetooth anymore. That was 2years ago. I recently found an article stating it was a two part update, the second part being a Bluetooth update. I may try that on a slow day, goodness why so difficult Pioneer?


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...