Jump to content
AVIC411.com
kojikurac

New here and need already help with Avic-F980DAB

Recommended Posts

First, hello to everybody, it´s nice that there is forum with a lot of helps and troubleshooting.

I have model Avic-F980DAB, until yesterday it was working fine. There is a but :), it happens once after he didn't successfully loaded into menu, it just restarted. Now is just worse, it doesn't boot anymore. Radio always stuck at boot logo "Pioneer" with bottom text "Loading..." and that is all. I tried to go in test mode with tesmode_a.key, tried with some combination keys like holding RESET,MAP,MENU,EJECT. It doesn't help. I´ve searched here on forums for similar problems with F88dab, F80dab, F980dab, F970dab. There is nothing useful for this model or I couldn't find it. I already download firmware from Pioneer, but it says I need to update trough menu. Is there any option to flash firmware over usb or SD card at boot with some key combination?

I would really appreciate some advice or help or something before I give up on radio.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×