Jump to content

Z140bh Unit is stuck in language selection mode!

Recommended Posts

  • TexasForever changed the title to Z140bh Unit is stuck in language selection mode!

Please describe the exact problem and how you got there. This isn't a common problem AFAIK.

Is this the first time you've upgraded? Also, is the parking brake set (or the parking brake been correctly bypassed)?


Link to post
Share on other sites

Everything was working fine, someone tried breaking into my truck a while back and ever since then it’s been powering up showing the pioneer start up screen then going directly to select language mode and once I hit ok it reboots and then goes right back to the select language mode, I’ve disconnected the battery, I haven’t checked the parking brake yet but this unit came with the truck when I bought it and I’ve had it 5 years with no issues until now. 

Link to post
Share on other sites

Has this unit ever had a map/software upgrade? Some functions will not accept input if the parking brake is not detected. It sounds like you are saying that you can select the language so it might not be a parking brake problem.

Just some random things to consider: Did the thief disturb and of the electrical wiring? Is there an anti-theft system in the truck? Did you have aftermarket HIDs installed? Did it ask you for a password when it booted? 

IIRC, the headunit only asks for language selection on a full reset. Disconnecting the battery only resets a few things. but not the language. The way to do a factory reset on the Z-140BT (according to the manual) is:

  1. Park your vehicle in a safe place and apply the parking brake.
  2. Turn the ignition switch off and back on. The navigation system restarts, and the splash screen appears.
  3. Press and hold the MODE button and the TRK (<) button while the splash screen appears. The “Select Items to Reset” screen appears. If you select anything other than "Cancel", the language and a bunch of other stuff gets erased.

If you didn't do this, something else is going on. Maybe the firmware or non-volatile memory got corrupted. There are a couple of things that could be tried by booting into Testmode but I need a clearer picture of what the current status is before suggesting any fixes that might just make things worse. Also, I haven't messed with one of these units in a long time and I'm kinda rusty. In fact, if anything on mine goes south, it will go in the trash. These unit's are far out-of-date and IMO not worth much effort to fix.

Link to post
Share on other sites

Yea, so basically nothing was messed with when they broke into it as far as I can tell, and actually right before it was broke into it was working just fine I mean it happened about 30 minutes after I got out of my truck, but then I turned it on and it randomly went to select program  language screen and the English is greyed out even clicking on other languages it will allow me to hit ok and once I do it reboots and brings the screen right back up and repeatedly the same cycle occurs, the actual fm radio works on it it’ll open the screen to eject cd or sd card but and the volume buttons work etc, it’s just the screen that doesnt allow me to get passed the select program the language mode it’s insane, it did recommend a firmware update while I was driving and I hit the button to accept it but it didn’t do anything so I figured it didn’t damage anything, but I’ve been stuck on this screen for about 4 months now and nothing I have tried has seemed to work, maybe the SD card is corrupted? Idk I need to take the unit out of the dash and look at the wires still so I guess I can start there. 

Link to post
Share on other sites

Since this was a pre-installed headunit I have no idea what the previous owner might of done to hack it. If it is running some hacked firmware like Condi's Hackmode, I can't help. Remove anything in the SD slot behind the screen just in case. There's no other user replaceable SD within the unit. Normally, the SD is just used for playing media files (audio and movies). It is also used to install firmware and boot into TestMode. It isnt necessary for normal operation.

These units don't ask for an update on their own. There's no external data connection. So if it asked to update something, it came from an SD or USB device that the user installed. Sounds like that's what happened and for whatever reason it failed and left the headunit in an bad state.

Before pulling out the unit, I'd try some simple things using Testmode. Download  supertestmode.zip (unzip it; copy TESTMODE.KEY to your FAT32 SD). Unfortunately TestMode has a very arcane user interface which is tricky to learn. There's some videos on Youtube that do a decent job explaining.

There is a manual procedure using TestMode to abort a failed update in some cases. Depends on how far it got.  Basically you:

  • boot into testmode. 
  • go into file maintenance
  • remove the file USER\SYSTEM\Download\StartKnd.log (if it exists).

This will kick the unit out of upgrade mode, and it should restart into regular mode on next power up (remember to remove the TestMode SD). You should be running with your previous firmware and maps.

If that doesn't pan-out, you can force the unit to use the backup firmware. There are two complete sets of firmware on the unit (/USER/PRG0 and /USER/PRG1).  When the unit installs a map update, it alternates overwriting one of them. It should overwrite the oldest. This is controlled by the presence or absence of the file /USER/PRG.FLG.  From memory, it works something like this: When the unit is brand new, PRG0 and PRG1 folders are identical and PRG.FLG does not exist. The next map update overwrites PRG1 and creates /USER/PRG.FLG (an empty file). The next time the unit is updated, it sees that PRG.FLG exists and overwrites PRG0 then deletes PRG.FLG. Then this cycle repeats ........

If you want to force the unit to use older firmware you can trick it - if /USER/PRG.FLG exists, delete it. If it doesn't exist, add it. Adding is a little tricky but a simple way is just rename any file on the SD to PRG.FLG. It can be an empty file since the only thing that matters is its name.  Then copy it to /USER in the head unit. Then remove the SD and restart the unit.

If none of that works, you can try loading (or reloading) the 2017 maps/firmware. See the thread in the Hacks sub-forum. You'll need to install the Shortfuse hack first to get around the Pioneer password registration key.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...