Jump to content
AVIC411.com
Sign in to follow this  
Sargasso

Galaxy S3 A2DP Mystery Solved

Recommended Posts

From the perspective of my Galaxy S3 it connects to my 930BT successfully in both phone and audio mode. However from the Bluetooth screen of the player the phone appears to be perpetually connecting. No songs appear in the directory and although play can be pushed nothing plays. I have played with the Bluetooth settings and re-paired numerous times to no avail. No A2DP success.

 

However today I discovered another way that works. Rather than connect via the Bluetooth settings start with the Android Player app. Use the menu ( lower left) button to share via other device. Select Bluetooth, connect to 930BT and voila, streaming audio. Note that this will not work if your phone is already connected. You must start paired but not connected.

 

Unfortunately this only starts an audio connection. To add a phone connection return to Bluetooth settings an check the phone box. Phone connectivity will then be added and things will work as I had hoped they would from the normal settings screen.

 

Based on the above I'd conclude the AVIC is functioning as it should but the Galaxy S3 lacks the logic to trigger the player to conclude the A2DP exchange.

 

I'll post this to a few Android forums and see if we can get that fixed.

 

Reply if this fixes your problem. I'd like some idea of how many people have this issue.

 

 

Share this post


Link to post
Share on other sites

I just upgraded my x930bt to 4.0 from 3.0 and now my bluetooth audio streaming does not function when paired using my galaxy s3. It worked great with the 3.0 x930bt software. Did you ever find another way to do it? I use the bt phone too much to have to switch back and forth from audio to phone manually...

 

**EDIT** Nevermind, I flashed a new kernel on my GS3 and it works great now.

Share this post


Link to post
Share on other sites

I'm not sure why, but now after executing the manual connection I described above everything works spontaneously as you'd expect. The only operational difference now between my old iPhone and the new GS3 is you must push play to start music streaming. The player starts in pause mode. The iPhone begins playing as soon as it connects.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×