Jump to content

SD Card / USB input not working

Recommended Posts

Dear all,


just a bought an used F900BT (EW version).

the drive was sold as being in mint condition and seems fully functional apart from the fact it will not recognize any SD Card or USB pen.


I've tried several brands/capacities and formatting options but still the icons on the Input selection menu are greyed out.

The unit was delivered with the original 2007 Teleatlas maps and i'm looking to update this and recover, at least, USB functionality.


Could the drivers be broken? Since no SD card is recognized, i'm unable to run testmode and make a backup.


I was not able to find a similar problem in the forum... can anyone help out?


The unit has V.2.009000 firmware & V.01.000800 maps



Link to post
Share on other sites

Ok, an update:


Just entered Service Mode (didn't messed with it) and on top of Uboot menu i have this reference: Avic-F700_R15_0319 256MB


Does this means that the unit have been flashed with a F700 firmware? Can this be the cause of my problems with the SD Card / USB input?

Link to post
Share on other sites

Thank you Pioneer4x4, since yesterday a new update:


i've tried an old 512MB USB drive and it works fine.


I also bought two new SD Cards to test (2GB Sony & Samsung) but the problem remains, i'm now almost certain that the SD input is broken and i cannot depend on it.


Is it possible to run testmode or do any update without the SD Card functionality? Can USB be used to backup and update the software version?


Thank you for the support

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...