Jump to content
AVIC411.com
mattesonb

Pioneer AVH-X8500BHS app radio mode issues with iphone 5

Recommended Posts

Yesterday i installed an avh-x8500bhs and everything seems to work except for some iphone functions. if anyone has gotten the iphone 5 to work on app mode please help me out.

 

i am running the usb to lightning cable and an hdmi cable to the apple video cable to my iphone 5, when i click on the appradio button it launches the "appradio" app and ask for permission on my phone to do so.  at this point the radio just mirrors my iphone screen no matter what application i am using.  there is no touch screen usability on the head unit itself, and the carmediaplayer app just show a picture of a cable being plugged in when i launch it.

 

at this point i dont know what to do

Share this post


Link to post
Share on other sites

Yesterday i installed an avh-x8500bhs and everything seems to work except for some iphone functions. if anyone has gotten the iphone 5 to work on app mode please help me out.

 

i am running the usb to lightning cable and an hdmi cable to the apple video cable

 

Are you using the Apple Lightning Digital AV Adapter?

 

http://store.apple.com/us/product/MD826ZM/A/lightning-digital-av-adapter?fnode=3a

Share this post


Link to post
Share on other sites

Where did you buy your Apple adapter and what did you pay for it?

i purchased it from apple through amazon for $39.99, its an authentic adapter and it plays video out on my tv flawlessly

Share this post


Link to post
Share on other sites

The biggest problem I'm having with this radio and my iphone5 is it recognizing the iphone.  I have to plug it in then check to see if it connected.  It doesn't then I reconnect it.  I have to do this several times and then it will eventually recognize it well some times.

 

Are you sure in settings you have it set to Iphone(digital av)?  I know obvious question.

 

I have noticed that I have more luck if I have app radio app running on the iphone but minimized and on the home screen when I connect.  It will then ask to allow it switch on the iphone and I click allow.  Maybe try that.

 

What I can tell you from my experience is it's very unstable to the point of unusable in my opinion.  Just this morning I decided to unplug the lightening AV, switch to the "others" setting and plug straight usb to lightening.  This puts it back to a regular usb ipod.  Pandora and playing music from the iPhone works good.  I'm going this route until maybe they update the firmware.

 

Keep us posted and let me know if you have any tips on getting the unit to recognize the iphone.

Share this post


Link to post
Share on other sites

The biggest problem I'm having with this radio and my iphone5 is it recognizing the iphone.  I have to plug it in then check to see if it connected.  It doesn't then I reconnect it.  I have to do this several times and then it will eventually recognize it well some times.

 

Are you sure in settings you have it set to Iphone(digital av)?  I know obvious question.

 

I have noticed that I have more luck if I have app radio app running on the iphone but minimized and on the home screen when I connect.  It will then ask to allow it switch on the iphone and I click allow.  Maybe try that.

 

What I can tell you from my experience is it's very unstable to the point of unusable in my opinion.  Just this morning I decided to unplug the lightening AV, switch to the "others" setting and plug straight usb to lightening.  This puts it back to a regular usb ipod.  Pandora and playing music from the iPhone works good.  I'm going this route until maybe they update the firmware.

 

Keep us posted and let me know if you have any tips on getting the unit to recognize the iphone.

its definitely set to digital AV because it wont even let me use the app button on the head unit until that is switched over.

 

at this point i may just switch back to regular usb until they update this crap

 

also what software version is your unit running?

Share this post


Link to post
Share on other sites

My Iphone 5 works perfect with my avh-x8500bhs

I was having same trouble you are till I turned App connection setting to

Iphone (Digital AV)

 

Wasn't east to turn that setting on I emailed pioneer, read manual, and lucked out and it changed, still not sure how I did it

Share this post


Link to post
Share on other sites

Remember to use USB 1 not USB 2

 

But your screen was same shit I was going thro till I changed that setting

And same problems too

Pioneer told me this radio was shipped with right firmware

Share this post


Link to post
Share on other sites

I'm running 8.19. iPhone is at 6.1.3.

 

I turned back on apps. When I did this I got the same condition as the OP. I then disconnected the iPhone, closed and reopened the app on the iPhone, plugged it back in and then it worked correctly.

 

T switch between others and iphone(digital AV). You have to turn off Bluetooth on the phone disconnect the iPhone and then you can go into settings and change it. It states that right on the screen.

Share this post


Link to post
Share on other sites

I'm running 8.19. iPhone is at 6.1.3.

 

I turned back on apps. When I did this I got the same condition as the OP. I then disconnected the iPhone, closed and reopened the app on the iPhone, plugged it back in and then it worked correctly.

 

T switch between others and iphone(digital AV). You have to turn off Bluetooth on the phone disconnect the iPhone and then you can go into settings and change it. It states that right on the screen.

 

 

yes it is correctly switched over to iphone (digital AV), i spoke to 2 techs at pioneer yesterday and both said the unit shipped with the correct firmware, today i spoke to another representative and he is telling me that it wont work until and update in the end of april (the guy was an idiot)

 

my phone is jailbroken on 6.1.2

 

unfortunately i dont have access to an unjailbroken iphone 5 right now to test it it is my phone.

 

are you using any type of bypass or properly hardwired to the hand brake

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×