Jump to content


Photo

Undo Condi's Hack Mode

X930BT X940BT Z130BT Z140BT

  • Please log in to reply
43 replies to this topic

#1 atlcarl69

atlcarl69
  • Members
  • 3 posts

Posted 29 May 2013 - 03:47 PM

I just got the "there is no applicable program" screen after running Condi's hackmode 2.x.  After doing a search, I didn't find a concise means of reverting back so I disected the installer and came up with the following:

 

Using Super TestMode

 

As with any mods to your AVIC, the following is at your own risk.

I was successful doing the following on my X930BT (updated to X940BT)

 

Step 1

From a PC create 2 directories on a SD card:

   PRG0 and PRG1

Copy the Super Testmode.KEY to the root of the SD card

 

Step 2

With the SD card in your AVIC boot into Testmode

   VERIFY THAT THE FOLLOWING FILE EXISTS: USER\PRG0\APL\AV1.EXE

      If it doesn't, do not continue!

   COPY USER\PRG0\APL\AV1.EXE and then paste into the PRG0 directory on the SD card

   If the following files exist:

      COPY USER\PRGx.FLG to the SD card

      COPY USER\PRG1\APL\AV1.EXE and then paste into the PRG1 directory on the SD card

Turn off your AVIC and take the SD card back to your PC

 

Step 3

From your PC

   Rename PRG0\AV1.EXE  to AV.EXE

   If the following files exist:

      Rename PRGx.FLG to PRG.FLG

      Rename the PRG1\AV1.EXE files to AV.EXE

 

Step 4

With the SD card in your AVIC boot into Testmode

   DELETE the following files on your AVIC

      USER\PRG0\APL\AV.EXE

      USER\PRG1\APL\AV.EXE

      USER\PRG0\APL\AV.MSCR

      USER\PRG0\APL\COMMCTR1.DLL

      USER\PRG0\APL\CORED1.DLL

      USER\PRG0\APL\KILLPROC.EXE

      USER\PRG0\APL\MORTSCRIPT.EXE

      USER\PRG0\APL\TOOLHEL1.DLL

 

   COPY the following files from the SD card to your AVIC

      SD\PRG0.AV.EXE to USER\PRG0\APL\AV.EXE

      If the following files exist:

         SD\PRG.FLG to USER\PRG.FLG

         SD\PRG1.AV.EXE to USER\PRG1\APL\AV.EXE

 

If you have followed the above exactly, your AVIC should be back to the way it was before the HACKMODE

 



#2 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 29 May 2013 - 07:16 PM

When that happened to me, all I did was to create a file PRG.FLG in the USER folder.  Problem solved.



#3 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 10 April 2014 - 03:00 PM

Device AVIC F930BT version 3.000

 

Question: I do not have or see a USER folder but NAND folder.

Is this the same as USER folder?

 

Is above mentioned working?

I am very anxious to do above mentioned, since my system does not boot any further as the first screen, it is bricked.

I did us Hackmode version 2.21, did not read all 67 pages.

 

Were can I find Super Testmode?

 

See also my latest post on page 67 of CONDI'S HACKMODE

 

Edit 12 April:  I can't delete NAND/PRG0/APL/AV.EXE from my device, it will not happen, what now?

Renaming is also not possible due there is no keyboard is available.

All the other files I did manage to delete.

 

Can someone help me?



#4 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 14 April 2014 - 08:30 AM

Anyone???



#5 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 14 April 2014 - 09:57 PM

First, get rid of HackMode v2.21.  Destroy it, obliterate it, throw it in fire and burry it very deep.

 

Second, "install" TestMode v1.4 on a SD card and boot your device with it.  There won't be any keyboard because you'll use the device's knob/buttons to input your requests.  If there are missing options, search the updated TESTMODE.key on this site to activate them.

 

USER folder and NAND folder are two very different folders.  If you have a USER folder, back it up.

 

Try installing a map update to (hopefully) restore your device back to normal.



#6 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 15 April 2014 - 12:54 PM

@Lyverbe: Thank you for your reaction and advice.

I used now the  SuperTestMode and suprisingly that works.

Now I see no longer NAND but a USER folder with same content.

I deleted all files which came with Hackmode 2.2. I asume there is no file left anymore.

I did also delete alle the files as mentioned on page 1, I asume that this deleting is also for PRG1, since is mentioned "ON YOUR AVIC".

Two questions:

  1. about Av.EXE and Av1.EXE for both PRG's: Are the content of this files equal? Because I was confused and throw some away and pasted them back from other safed files.
  2. I do not have a PRG.FLG file, so I could not place this file in the PRG0 folder. Any idea how to do so? Is this file nesseccary?

After done all this the system does not start up. I do only see the "NavGate" screen.

If I only could see the complete folder/file content of a working system.

 

You did advice me to try to install a map update. I do have the Avic 2013 EU Update for my device.

It brings my device to version 5.00, while I do have now version 3.00.

Is that a problem?

 

I do appreciate it very much that you are the only one, at this moment, which is trying to help me. :?

Hopefully you can help me with the correct answers. :idea: If it is easier to communicate directly (by email with photographs of my system?). please tell

Thanks for now.

John



#7 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 15 April 2014 - 09:58 PM

A lot of users can help you, but we're so tired of fixing damages caused by HackMode v2.21 that we're giving up.  I've suggested many times to administrators to add a huge "WARNING" message next to the v2.21 download link, but they don't.  We, the users, are stuck helping the poor souls who installed v2.21

 

So...

 

AV1.EXE is a backup of AV.exe.  You should be able to restore your original AV.exe with it.

The PRG.FLG file has no content.  It's an empty file that indicates the system which USER folder to use.  If I remember correctly, the system will use the USER\PRG folder if the PRG.FLG file is present, or use the USER\PRG0 folder if it's absent.  You might want to try adding the file and see how the unit reacts.  It could fix your issue.

 

I don't believe going to 5.00 from 3.00 is a problem.  Pioneer cannot expect everyone to update their unit one version at a time, so I assume it's supported although I haven't tried it myself.



#8 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 16 April 2014 - 08:27 AM

@Lyverbe

Thanks again with helping me.

 

Av.EXE is done as described. Its 8kB.

PRG.FLG file is not to create since in the PRG folder, it will be a folder, then.

How to make this an empty file with correct extension .FLG?

How does the icon looks like?

 

Edit: I think that the icon looks like an empty sheet in which the right-above-corner = folded

I found and did copy a same FLG file from my (still not executed) update 2013: UPDAT/USER/SYSTEM/BG/OPENING.FLG

This file is also 0kB and I renamed it to PRG.FLG.

Now I have to copy this file into the USER folder of my device and try to start up the system today, hope this will work.

 

Edit: It does not work!! I was hoping to fix the working of version 3.00 before any update 2013.

I do not know anymore what to do. I did tried all suggestions I have read!

I am afraid to update with 2013, because I am anxious this will mess up totally.

 

Edit 17 April: Did found a PRGx.FLG file in the update, copied to SD card and renamed it to PRG.FLG, tried to paste it in the USER folder but thid will not be executed.

Also tried to copy complete USER folder from my device but this will also not be pasted to my SD card.

 

Another question: I do see in the update 2013 that the Av.exe is a file with an icon that looks like an explorer window and it contains 4.119kB.

It is different as the one in my system, which icon looks like a flagging sheet with (written) lines on it but this contains only 8kB). This file says under "Properties" under the description "MortRunner". So I think this is not the correct Av.exe.

Could this be the causer???? What do you think? Should I try the AV.exe file that contains 4.119kB? It will execute something!!

 

I like to receive some advices, tips or hints before I try ultimately the Update 2013.

Is there anyone who ......??

 

It is very dissapointing that the forum moderators let this Hackmode version 2.21 exist.

Fortunately I found the SuperTestmode key, but still, my device is not working.

 

 

Lyverbe: Thanks again for your help, I let you know if ........................

John5



#9 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 18 April 2014 - 03:27 PM

@Lyverbe or anyone else:

 

Why is no response?

Yes, I do understand, you all are sick and tired to help guys which were not smart enough to read all 67 pages of CONDI's HACK.

Yes, my device is bricked now. I did anything to restore it. I did make backups of user folder with SuperTestmode and most everything I read.

All my files in my unit are original, except for the Av.EXE. I was so dumm to switch them and did throw away the original one.

I kept, fullisness, the Av.EXE as Original file while the Av1.EXE is the Original after renaming to Av.EXE.

Normally you can not past a same named file into the software, but I assume Condi's software did rename the Original Av.EXE into Av1.EXE.

 

Now I do need from someone an Original Av.EXE.

Is there someone who is willing to supply me this file?

 

In my despair, I did tried to install the Avic 2103 EU update, in the hope this will repair my unit, but the update will not start.

 

Is there anyone who has tips or advice for me.

Is there somebody in the Netherlands (or anywhere) who does understand how to repair my unit?

 

Regards from John 5



#10 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 18 April 2014 - 09:45 PM

I don't know about the other members, but I see posts using the "New Posts" feature of the forums.  If you edit an existing post, it won't show up as a new posts and we won't see it.  That's how I explain it.  ... but yes, we're also sick and tired of fixing HackMode v2.21 screw ups :)

 

I've shared my X930BT original AV.exe (3.001) on my DropBox for you: https://www.dropbox....cyfmzgk6/Av.exe

 

Good luck.



#11 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 19 April 2014 - 09:48 AM

@Lyverbe:

 

Thank you very much for your comments and Av.EXE.

I see this contains more as the 8kB, which are in my ..../Apl/Av.EXE.

I will put it in and hope this will help me. :mrgreen:

I assume that the Av.EXE of your F930BT of Canada will be the same as for my Europe software?

 

What about my posts: These were intentionally ment as reaction to the Undo Hack, which I performed completely and had no result.

If your last attempt to help me will not have succes I will try something with the 1.4 hack version.

And then when I need again help I will start a new thread.

 

Thanks again for sharing and I will inform you about the results.

 

Greatings John5



#12 John5

John5
  • Members
  • 13 posts
  • LocationNetherlands

Posted 22 April 2014 - 03:16 PM

@Lyverby

 

Thank you Lyverbe.

I did manage to restore my F930BT device. I did not succeed by using the SuperTestmode. Whenever I tried SuperTestmode, to paste the Av.EXE file into USER/PRG0/Apl/...., the "Paste" button stays gray. Whatever I tried I did not manage. Ultimately I had to use Condi's Hackmode v. 2.21 again (allthough I was very anxious to use it again).

When the explorer finally appears I was able to past the Av.EXE file into above mentioned file place. I did checked if there were any of the files to deleted in the ...../Apl which are prescribed on page 1 of this forum. This was not the case. There are present in the PRG1 folder. But they will do no harm there. I now know how to work with some of the modes.

When I did leave the Hackmode and turned the engine/motor(electricity) off and opened the door (for the final shutoff), and I started the engine again the Pioneer unit started up in a way if it was never bricked.

I had a lot of stress after it was bricked. :?

I was afraid that my wife became aware of my Pioneer problem.

Thank you again, I am in a dept with you.

If you ever come to the Netherlands we will drink a lot of beer, all night!! :-P

 

John5



#13 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 22 April 2014 - 09:55 PM

HackMode v2.21 saved the day.  That's a first!

 

Glad it all worked well for you.



#14 jtlaidlaw

jtlaidlaw
  • Members
  • 4 posts

Posted 15 June 2014 - 07:46 PM

Okay - not sure who is still following this thread - been working at it/reading this and any other thread pertaining to the X930BT ever since mine died about a month ago.  Had to have my battery replaced in Boston and the unit passworded out.  Then bought a new GPS unit as I lost my nav system through this while touring 7 major cities.  

 

I got home - called my original pioneer dealership and nothing - all I was told is send the unit in and maybe they could fix it.  I installed Codne's hack but it would never reboot the av.exe file.  I am now stuck with something I can either put the hackmode.key or some version of the testmode.key up and that's it.  I need to first know if I am using the correct version of the testmode.key as I am unable to "copy/paste" the aforementioned files.  

 

I've seen where the one gentleman has made his av.exe file available via dropbox bu am a bit leary as it's a Europeon version and I am in the U.S.  I'd really like any and all help to make this unit functional as I am 1. not ready to buy a new car, 2. not dropping another 1k dollars into a stereo/nav unit due to the cars age.

 

You can email me direct at mt_outdoorsman@yahoo.com.

 

Thanks in advance for any of you still following.

 

Regards,

 

James



#15 Lyverbe

Lyverbe

    Member

  • Members
  • 154 posts
  • LocationMontreal, Quebec, Canada

Posted 15 June 2014 - 10:33 PM

I'm the one sharing his X930BT's av.exe and I'm in Canada. You can always give it a shot after first taking a backup (i.e. rename) of your own av.exe
https://www.dropbox....cyfmzgk6/Av.exe





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users