Jump to content
AVIC411.com

AVH-4200NEX no AM/FM display+ tuner not working


Recommended Posts

everything seems to work great in the receiver except the radio tuner. :???:

Since I bought it (2 weeks ago) , no AM/FM is being displayed on screen despite selecting the HD Radio option . 

 

my question ( if someone experienced this before) :

in case of the antenna failure, is it true that the tuner will never work or display AM/FM frequency? regardless the quality of the signal reception.?

 

 

 

 

Link to post
Share on other sites
  • 2 years later...

Did you ever figure out the issue here? I have an AVH-4200NEX. Went under some low hanging trees that hit the antenna and suddenly I had a similar issue on the HD radio. All my presets disappeared and there were no tuning options. Checked the connections on the back of the radio and they were fine. Also checked the wire going into the antenna as best I could tell with the passenger door open. Could be that the antenna is damaged somewhere else, but it strikes me as odd because I drove an older Jeep where the antenna was physically broken off and I could still get a couple of the strongest stations. Not sure if the Pioneer disables the tuner if it doesn't pick up anything? That was your question and mine and it was never really answered.

Link to post
Share on other sites
  • 8 months later...
On 9/28/2019 at 3:30 PM, MacsAre1 said:

Did you ever figure out the issue here? I have an AVH-4200NEX. Went under some low hanging trees that hit the antenna and suddenly I had a similar issue on the HD radio. All my presets disappeared and there were no tuning options. Checked the connections on the back of the radio and they were fine. Also checked the wire going into the antenna as best I could tell with the passenger door open. Could be that the antenna is damaged somewhere else, but it strikes me as odd because I drove an older Jeep where the antenna was physically broken off and I could still get a couple of the strongest stations. Not sure if the Pioneer disables the tuner if it doesn't pick up anything? That was your question and mine and it was never really answered.

I came here to mention that this happened to me as well. I’m on my second avh 4200 nex radio with the same issues described here. The first one had exactly the same issue but was replaced under warranty. Now this one is out of warranty and I honestly have no idea on what to do

Link to post
Share on other sites
  • 1 year later...

Mines doing the same thing avx-w4500nex pioneer needs to fix this problem it seems like a lot of radios are having this problem and when you call Pioneer they want you to send it to someone that’s going to charge you $175 to look at it plus parts and plus $16 to ship it back to you

Link to post
Share on other sites
  • 2 weeks later...
On 6/13/2022 at 4:02 PM, Scheider1980 said:

Mines doing the same thing avx-w4500nex pioneer needs to fix this problem it seems like a lot of radios are having this problem and when you call Pioneer they want you to send it to someone that’s going to charge you $175 to look at it plus parts and plus $16 to ship it back to you

 

F0EBCCFE-C070-4E61-AF61-4B161A34BF30.jpeg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...