Jump to content

4400 NEX Wireless CarPlay on New iPhone issues

Recommended Posts

I am having issues with my 4400NEX (latest firmware) and CarPlay via WIFI. Wifi CarPlay works flawlessly with my iphone X on v13.3.1. If it doesn't connect automatically, I can go to the Top Menu Screen select the phone icon and my iPhone X is listed. I can then select my iphone and it connects via wifi. No issues.

Now I have an iPhone 11 Pro Max on v13.3.1, I have connected it to the 4400NEX via usb, bluetooth and wifi and it works perfectly the 1st time. The problem is when I turn the truck off and start the truck up again the 4400NEX wifi doesn't connect to my iPhone. So I go to the top menu and when I select the phone icon all I see is my old iPhone X listed. My new iphone is not listed. If I go to my iphone 11 Pro Max settings select general > CarPlay > AVH-4400NEX > the CarPlay is on. But if I turn it off and on again the 4400NEX sees it and connects. I can plug my iPhone 11 Pro Max in by usb and it works flawlessly. But if I wanted it plugged in I wouldn't have replaced my 4200NEX with the 4400NEX.

I've completely reset the radio, the phone, deleted everything from bluetooth on both the radio and phone and nothing seems to work. I can also find no way to get my old iphone deleted from the CarPlay wifi. I've deleted it from bluetooth no issues. But its still in the CarPlay wifi menu.

I was hoping maybe someone on here had a similar issues and could help. Thank you for your time.

Link to post
Share on other sites
  • 6 months later...

4400nex and iPhone 11 here. Same issue with wireless Carplay. I have to go into Settings > Bluetooth and tap the 4400 to connect, then go out to the head unit and search for it to connect. Such a pain in the ass. My old iPhone 8 Plus still connects flawlessly to the 4400 (even on iOS 14), so I strongly suspect it's something iPhone 11 hardware-specific.

Long shot, but did you (or anyone seeing this) ever manage to overcome this issue?

Link to post
Share on other sites

I just upgraded (on Friday) to an iPhone 12 Pro and now I'm having this exact issue with my 4400NEX as well. It worked fine 90% of the time with my iPhone X.

I've tried the menu reset and the paperclip 20 second reset, and neither of them seems to completely wipe the unit since I still see the name of my old iPhone on the connection screen. I've also never had luck with upgrading the firmware on my unit - it puts me through hell thinking I've bricked my $600 head unit and then reboots with the same v1.0 firmware. 

I called Pioneer and she said they had no knowledge of an issue and told me to reset it. 

Could it be an issue with a connection to new hardware that was restored from old hardware? It would seem a factory reset would solve it, but again, I can't seem to do a "true" factory reset. 

Link to post
Share on other sites
  • 2 weeks later...
  • 3 months later...

Exact same problem when I upgraded from iPhone X to iPhone 12 with my Pioneer AVH-W4400NEX in my 2015 Honda CRV with Maestro HO2 wiring harness.

Can't clear my old iPhone (or any other devices) from the Bluetooth connections. Tried clearing the bluetooth memory and resetting the whole unit to factory settings. But the bluetooth connections always return when I restart my car.

Reviewed the wiring, tried a Microbypass switch, and the parking/ground "Set On" menu trick. No luck at all.

Any updates from others here??

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...
  • 1 year later...

Good morning everyone,

I had the same issue and can confirm that by burning the software image in a brand new SD card fixed it. Response seems to be faster now as well.

Follow this procedure to burn the image to the SD card. The original POS card is 8GB but you can get a 16GB card which is what I got and worked perfectly.

Image burn process -> http://avic411.com/index.php?%2Ftopic%2F90534-how-to-fix-for-avh-w4400nex-boot-loop%2F or here 

***Note*** This image is ONLY for the AVH-W4400NEX and will not work in other models. The image is version 1.02 which is the latest one.

SD card -> https://www.amazon.com/dp/B013CP3JDO?psc=1&ref=ppx_yo2ov_dt_b_product_details

To access the internal SD card follow this. You just need to remove the plastic frame as shown here https://www.youtube.com/watch?v=0eCvEen1p0g&t=41s

My guess is that with time and being on and off many times gets the internal SD corrupted to the point that the radio starts acting like this

Hope it fixes it for you as it did for me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...