Jump to content

A FIX for Euro F900BT that hangs on splash screen with all Euro files needed

Recommended Posts

Hey everyone


About two weeks ago I accidentally wiped my files from my unit and have since then reading through threads on this amazing site and in all honestly all credit goes to a member on this site by the name of TAIL24 who seriously helped with all my question.


As i was going through all the threads I found that a lot of the links were down or no longer working, or that most files are of the US / CAN models, so seeing as I managed to get my unit back and running after so many trials i decided to help the gents and ladies of European F900BT owners.


After deleting my files from my unit I tried various fixes , but I always ended up with the following


1. my unit would just hang on the pioneer splash screen and no matter what button i pushed nothing happened


2. or it would show the DESTINATION, CONTACTS and AV SOURCE buttons , but the "System is starting up , please wait" message would not disappear and if pressed the menu button it would only me to access the setting and nothing else, some time I could access the AV source and sometimes nothing happened if i pressed it, and when i pressed the map button or destination icon it would take me to the disclaimer screen then hang.


I am not sure but i think this will work for the F700BT but as I said I cannot guarantee that as it was just tested on my own F900BT. I would highly recommend that if you are not computer tech savvy then find someone who is and is wiling to help you.


all the procedure below I learn't from Tail24's threads and other members on this forum, I am just pulling it all together with the files to make it simpler for euro owners to find.


before we start I must stress that I am in no way liable for any damage to your machine, please use this guideline at your own risk


ok here we go, I cannot stress enough that you must follow these steps carefully, I would highly recommend that you use a NON MAC pc and have at least three 4gb SD cards and make sure you format them to FAT32, I tired using this on mac and had no luck , so I decided to do it on a windows laptop and seemed to work. i would also recommend that if you have a laptop with a inbuilt SD card reader, that you download or copy all the necessary files to it and take with you into the car as it will make life so much simpler than going into and out of the house.



1. On your desktop or where ever you prefer, Create a new folder and call it AVIC Files or whatever you want to call it, this will hold all files you download

in this folder please create the following sub folders


pioneer firmware V2.009


Pioneer Update firmware V3.021




Avic Euro backup







2. please go to the pioneer website http://www.pioneer.eu/uk/support/software/AVIC-F900BT/index.html and download the following:


First download the firmware titled AVIC_F700BT_F900BT_VER_2009000.zip Version 2.00900, you will need this to bring your wince to the basic firmware


Second download the Update firmware titled AVIC_F700BT_F900BT_CNSD100FM_VER_3021000.zip

version 3.021000, you will need this at the very last step


I would recommend winrar http://www.rarlab.com/download.htm ( you can download which ever suits your windows version ) to unrar the files once downloaded


ok once both files are downloaded use winrar to unrar them and place each one in their separate prospective folders that you created in step one ie Version 2.009 goes to the folder called pioneer firmware V2.009 and the update 3.021 goes to Pioneer Update firmware V3.021, you must keep these separate to avoid confusion as both pioneer couldent be bothered to rename the firmware folders differently.





3. Download the SDMLC File from here http://webdesignsfor.me/avic/files/SDMLC_NN746_EW_sn00aa0f.rar

again once downloaded unrar and put the folder into the EURO SDMLC you created earlier






Thanks to an Italian site i found a link to on this forum I managed to find a backup to the euro units


4. Download the My Flash Back up from here http://webdesignsfor...lash%20Disk.rar


again once downloaded unrar and put the file in to you Avic Euro backup folder you created earlier





This is a important file as this will allow you to access your WINCE


5. Download the testmode file from here http://webdesignsfor...es/testmode.rar


once again when unrared please put into testmode folder you created earlier





Once all the steps above are done you will need at least 3 SD cards of at least 4gb each



6.Now you will need go to the folder called pioneer firmware V2.009 , open up the folder called LPUE080 and look for a folder called PLT and inside that folder you will see 2 files called WINCEIMG.BIN & WINCEIMG.CKS highlight and copy these two files ( COPY ONLY DO NOT CUT) , now get the first of the SD card that has been formatted to FAT32 and paste those two files to the root of that SD card, after that please copy the whole folder called LPUE080 that you copied those WINCEIMG from and also put it into the root folder of the SD CARD.


That the first card finished with, if you write on mark it pioneer 2.009 & wince so you know whats on it


7. 2nd SD card you will need to go to the folder called EURO SDMLC and copy the file inside that to the 2nd SD card, also long with that please copy the testmode folder as well and again if you can mark on it Euro SDLMC, testmode


8. Now you will need go to the folder called Avic Euro backup open it and copy ( copy not cut) the file inside called My Flash Disk and then paste into the 2nd sd card also with thet you need to copy the testmode folder to that same sd , so you end up with two files, My Flash Disk & Testmode


we will leave the folder called pioneer update firmware v3.021 till later.




9. now take those three SD cards to your car and hopefully you have marked whats on each of them

ok take the first sd that has the winceimg and v2.009 firmware on it and while your car is off put it into the SD slot of the F900BT , now its a bit tricky , but you need to hold Menu, Map, Eject & reset button all together while your start ur car so that the machine tune on , u just had a pen in my mouth , held teh button with my left hand , turned on ignition and quicly used my right hand with the pen to press the rest, after 2 or 3 seconds ONLY LET GO of the rest button and wait, you will hear a pop from your speakers and then you unit will go into a blue screen which will say to press reset again , DO NOT DO THAT , just enter the service code using your volume knob , the code is

UP,UP, DOWN, MENU, LEFT, RIGHT , after that you will see menu choices , make sure your SD is in teh slot and choose the first option to upgrade wince, this will take you to the second menu, from that choose option one again called UPGRADE USING SD/USB ( FORMATED) , please make sure its the Formated option .


this will start reading from your sd card , leave it alone untill it says [image updated ok , please reset your machine,] now leave the sd card in the slot and switch off your car, wait abiut 5 seconds then turn it on again ( please make sure your car engine is on you dont want any power distrubtions), and wait ,after about 20 seconds or so it should show you a white screen and start to copying the firmware leave it alone but keep an eye on it, once its finished it will restart, make sure you take out the sd before the unit comes on again . wait for the unit to come one then turn off your car


10. now put your 2nd SD card with the SDLMC and testmode into the slot, TURN YOUR CAR ON with engine running, Make sure its running for the whole of the next steps, this will take you to the WINCE which will look like the old windows xp , now from here on you must be careful.


11. look for the icon called DiskRW and double click on it, after ut opens please do the following:

  • you will see a little dots near the top of the program window change the little dot in this program to Write (instead of read)
  • click on the first drop down menu and find where it says SDMLC and make sure that shows in the window
  • Click on the button that has the three dots (...) and brows to your SD Card and then find the file

SDLMC_NN746_EW_sn00aa0f.IMG and double click on it, if double clicking is not working, then you can highlight the file again and

  • click on "ok" in top right corner of screen, this will take you back the diskrw program then click on "write" which is in the middle on the right of that program window.
  • You should see the blank text box start to run all sorts of text info then it will show stars ie( ********* ) for a while until it is complete, once it done it should say something like complete or successful, Once the IMG has been written successfully close that program window which will take you back to the desktop.

12. from here remove the SD card from the slot and replace it the sd card that contains the Avic euro backup called My Flash Disk, after its inserted double click Start/Programs/Explorer or look for which icon can take you to the explorer window, once there look for an icon called MY STORAGE, double click that and you will see your folder called My Flash Disk , double click on that to open it, the click on edit , Select all, and that should highlight all the files, then click again on edit and then copy, from here press the back button navigation ( which is on the top same row and file, edit etc etc it will look like a yellow arrow going backwards) until you are back and can see MY STORAGE icon again, if you look to the left of that you will see another icon called My Flash Disk , double click on that to open it, once open click on edit and paste, it will start to copy don't worry if it says not enough space just yes to continue, and then it will say do you want to copy over existing files make sure you SAY YES. now leave alone as this will take about 20 mins or so.


while this is happening and you were able to take your laptop with you , choose one of the sd cards already used and format it to FAT 32 again, if not just wait till the step above finishes.


if you do have your laptop with all the folders that were created please go to the folder called Pioneer Update firmware V3.021 and copy what in that folder to the freshly formatted SD card.


if you don't have a laptop and need to access your pc the wait till the above steps finish , turn your engine off , return to your pc , format one of the SD cards to FAT 32 and place the folder called LPUE080 into that sd card and take it back to the car


13. once you have that 3.021 update firmware folder ( LPUE080 ) on your SD card place it into the SD slot on the unit and turn the car on with engine, wait about 20 seconds and hopefully if all went well it will take you the similar white screen as when it did the first firmware install and it will start to update your unit, leave it alone till it finishes but again keep an eye on it , once it finished it will restart the unit, please please make sure you remove the SD card before unit starts , give it a full 2 or 3 minutes to initialise , and if everything went well your unit should start normally.


regarding updating the Maps that's another story altogether and there are many threads on here that tell you how, but most importantly do not delete or mess your wince files unless you have a back up, if you want a back up of your files , all you do is put testmode folder on to a SD card, put into sd slot on unit , turn on car with engine running, once in WINDOWS , just browse to MY Flash DIsk , click edit , click select all, click edit ( again) , the copy . then browse back till you see MY STORAGE, double click it to open it , once its open click edit and then paste , should take 20 mins or so to copy to your SD card, once done remove SD card and turn off car and that's it



I hope this helps many of my fellow Europeans who are struggling with the F900BT and as I said I think this might fix the F700BT but I am not about that or other F series units.


again a special thanks to TAIL24 for the help and support and of course too every one on AVIC411 which without them we would all be owners of expensive paperweights.

Link to post
Share on other sites
  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

  • 4 months later...

basically yesterday my f900bt all of a sudden went black after splash screen it would show me black screen i couldn't do anything at all, it wouldn't function.

i came across this post after searching so much on the net.

however i have tried all your steps and its not working for me. i tried it a few times done everything as you said but still no hope, it came on but then 'system startup in progress' wouldn't go, if i went to maps/destination then it would hang and restart. I checked the version it was on 3.0....etc.

just to mention i got so annoyed after spending so much time that in the my flashdisk in WINCE i deleted all them files and i didnt have any backup and copied the ones i was supposed to as above done everything but same thing is happening 'system startup in process' repeated the procedure a few times but no luck.

i am in UK, also this torrent doesn't work.

just to let you know i carried out all your steps as you have mentioned, very simple and easy thank you but please help me this is making me go insane.


just to let you know this is what i did in summary:

all files i downloaded in your description/links.

v2 downloaded from pioneer site.

copied 2 files, then the folder to mmc root.


then SDMC from the link you gave with test mode.

selected write, then it restarts after the *** so i repeated the process and then the message came up 'successfully written IMG' ....etc.


then my flashdisk backup that i downloaded from your description with testmode,

copied flashdisk files from storage to original flashdisk in WINCE just as you describe above.

however i noticed that after i deleted all the files from original flashdisk i dont get that message anymore that theres less space etc. which i did get it before like when the first time i done it. but it copied allright with no error.


finally v3. LP.....etc folder into mmc i did wait for the update to go 100% and before restarting removed the mmc. but when it boots 'system startup doesn't go and it restarts after a bit.



please help me.

Link to post
Share on other sites



try these files m8 and follow the same procedures. Oh and I did mine all off 1 sd card without having to keep going back to the house or take a lappy to the car.


You probably shanked your unit the same way I did, trying to upgrade or install Diaftia's mod and not backing up your flashdisk first.


Remember the golden rule; Make a backup first!!


Good luck.

Link to post
Share on other sites

thanks i will start downloading now and update you on here, but is any of the files above ^ not for UK because i used everything as explained but i still get system startup in process please wait' and then it reboots.

because if the torrent has same files i dont think it will solve the problem, thanks for your reply

Link to post
Share on other sites



try these files m8 and follow the same procedures. Oh and I did mine all off 1 sd card without having to keep going back to the house or take a lappy to the car.


You probably shanked your unit the same way I did, trying to upgrade or install Diaftia's mod and not backing up your flashdisk first.


Remember the golden rule; Make a backup first!!


Good luck.


These files are the US files. If you did SDMLC files of a US in a UK you prob will get bad effects. But there were also UK SDMLC files in there.


The back up is also US so that won't work, you'd need a euro backup like from this original post.

Link to post
Share on other sites

yes im using mac, but i can surely say that i have formatted the SD card properly in FAT 32 through disk utility the proper way. but unless theres another reason ??

thanks please do let me know


mac puts a bunch of extra hidden "junk" files that this unit doesnt like

you will need to get rid of the extra junk files in in the \APL2\IGO\CONTENT\LANG folder, leaving just the real zip files

Link to post
Share on other sites

These files are the US files. If you did SDMLC files of a US in a UK you prob will get bad effects. But there were also UK SDMLC files in there.


The back up is also US so that won't work, you'd need a euro backup like from this original post.


tail24 - thanks for your reply, i have now given up after wasting a full week.

i used SDMLC for euro how i know that its for euro is as you say the EW in the name.

i managed to download a euro backup of f900bt & someone also on here sent me their copy, thanks to 'ovalball', i tried both copies but no luck. how i know its for euro is all the maps are of European countries when i check the folders.

i followed all the same procedures, dont get any errors when installing but when completed it still says 'system startup in process please wait' then reboots after 5 mins approx.

dont know what im doing wrong or whats causing this.


just to summarise i did ;-


1: wince upgrade -> v2 -> PLT -> copied 2 files to SD root with actual folder-> wince upgrade from service menu -> format option -> upgrade ( approx 12 mins)


2: SDMLC EW -> SD root with testmode v2.3 -> write disc -> once successful close window replace SD with SD #3


3: euro My Flash Disk -> SD root with testmode v2.3 -> copy & paste all into My Flash DISK ( aprrox 20 mins to complete ) -> turn car off


4: upgrade using latest firmware v3 as described ^ (20 mins aprrox)


still doesn't work as it shows system startup in process and then reboots.



just wasted so much times tried literally all the posts but doesnt work.

thanks to you guys for even reading and replying

Link to post
Share on other sites

just deleted them files, the junk was only the different languages so i deleted them all apart from english uk and english uk2 just as how it was in the back up. it did nothing, also disconnected gps that didn't solve the problem. i think im doing something wrong, way too wrong.

Link to post
Share on other sites

Great work :-)

Followed your instructions and now my F900 is back in business.

Only problem is that the fix seems to have changed the "product device number" of the unit. This means that I can't re-install my cnsd-300fm update since it's locked to my "old" device number. Really weird, thought the device number was unchangeable but apparently not.

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...