Jump to content


Photo

Galaxy S3 compatibility to X940BT

Pandora Aha Radio Galaxy S3 Android Compatibility

  • Please log in to reply
7 replies to this topic

#1 kware1

kware1
  • Members
  • 13 posts

Posted 06 June 2013 - 01:37 AM

Hello Folks-

 

I need a difinitive answer on whether or not my Galaxy S3 and Pioneer Avic X-940BT can communicate and control Pandora and Aha Radio via the Pioneer interface. This is an update from the 930BT, so I don't know if that's where my issue lies. The Blue Toothe, phone contacts and everything else works fine but the Pandora and Aha Radio just wont connect.



#2 Bender

Bender
  • Members
  • 5 posts

Posted 06 June 2013 - 01:51 AM

I can get a definitive answer for you tomorrow night.



#3 brtnbrdr

brtnbrdr
  • Members
  • 1 posts

Posted 16 June 2013 - 07:12 PM

I have a GS3 and an X940BT installed in my truck, and have no problems at all.  Sometimes the bluetooth takes 2 attempts to connect, but that's about it.  Make sure to check in Settings and verify that App Mode is set to Bluetooth, and not Wired.  It defaults to Wired, and Pandora and Aha won't show up unless you change it to Bluetooth.



#4 kware1

kware1
  • Members
  • 13 posts

Posted 22 June 2013 - 04:28 PM

Thank you. The system is set to blue tooth. it will work via blue tooth audio and phone. the reason I bought this unit was because I wanted to have full control of Pandora on my screen.

#5 DracoAzule

DracoAzule
  • Members
  • 7 posts

Posted 04 July 2013 - 04:40 AM

Hey.  I just updated mine today actually.  I had the same issue until I went into my bluetooth settings and did a firmware update which was included in the update package you put on your SD card.



#6 jayno20

jayno20

    Member

  • Members
  • 23 posts
  • LocationPittsburgh, PA

Posted 08 July 2013 - 06:41 PM

Are you getting a message on the head unit while trying to connect pandora saying something like check your phone when you can lawfully do so?

#7 Felipeburtch

Felipeburtch
  • Members
  • 1 posts

Posted 13 January 2017 - 12:58 PM

I just baught this deck. Avic 940bt.. did the updates from 4.0 to 5.1.. and now aha and pandora are gone from the screen.. also I have an android galaxy6... what do I do? Plus I wanna know how to get to appradio. Help guys:)



#8 RonS

RonS

    Established Member

  • Moderators
  • 1360 posts
  • LocationBelleair Beach, Florida

Posted 13 January 2017 - 01:50 PM

I just baught this deck. Avic 940bt.. did the updates from 4.0 to 5.1.. and now aha and pandora are gone from the screen.. also I have an android galaxy6... what do I do? Plus I wanna know how to get to appradio. Help guys:)

For any weirdness after a firmware update,  the first thing to try is a hard reset (disconnect battery for a few minutes).

You will loose some settings and may need to re-pair BT.

 

Why didn't you for directly to 6.0? You don't need to install all the intermediate updates.

 

Make sure AV System Settings/App Connection is set to Bluetooth.

 

I've never had any luck with "App Mode" on an Android device. Its been a long time since I tried, so maybe it works. Its mainly for iPhones.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users