Jump to content

software error screen

Recommended Posts

Just made an account on this forum just to post on this thread :P

I have an AppRadio4 (SPH-DA120) in Canada which has worked fine for 3 years, with the odd weird issue which was resolved by rebooting my iPhone or restarting the car.

But now I have the "Software Error" screen no matter what I try. So, I'm going to try to replace the internal SD card and use the US backup image posted earlier in this thread.

I'll report back with my findings/results. If successful, I'll try to document the steps easy enough for anyone to follow. I'm on IT technician/server admin so the technical side of this should come easily enough.



Opened the radio, removed the 4GB Transcend SD card, confirmed it does not appear in Windows at all. Stupid CMD42 lock -_-

Went and bought an 8GB microSD with SD adapter and am restoring the Canada/US image file to it now with Win32DiskImager. 

Popped it back in the head unit, reinstalled in the car, and it booted successfully! 

Was also able to update the firmware after, took some playing around with the USB drive though (correct formatting, placement of file, etc.)


Posted my walkthrough with some photos on reddit if anyone can benefit from it:


Link to post
Share on other sites
  • Replies 174
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 2 weeks later...
On 12/22/2016 at 6:33 PM, crunner said:


I have this problem (software error) on my 4000nex. I know how to get the internal SD card out - I've already done it. If you have a backup image that's suitable I'd love any assistance you can send my way.


The internal card is a cheap-ass Transend 4GB, btw. What kind of idiot engineers at Pioneer chose SD memory as a long term storage solution? Most raspberry pi users know if you hammer the SD card (by swapping on it, for example) it'll fail pretty quick, sometimes within days.



Thanks if you can help, asd255. Or anyone else out there.



Same here I just had his issue happen to me. I took out the sad card but can’t find the back up image

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Good evening, (google traduction ;-)  )

I am disgusted because following an update of my car radio Pionner AVIC F860BT I have a software error message from the start of the post. Of course the reset does not work at once. I searched on a lot of forums and I understood that it was the software on the internal SD card that is corrupt. Can not find an image file of my post (it seems that it is a NEX5000?) And besides I thought to see one and I install it on the map this last is full of partitions without anything in it and a Once put in the post we can not read it anymore ... the cat what! I had a contact with the company that manages the service of Pioneer (SID in Marseille) and they can send me one for the modest sum of 161e + 12e of postage since it is very very heavy a SD card lol the price of the post in OCCAZ: cry: There is something about Ebay abroad in the 100th but the delays are long and nothing certain .... So the question that kills: can someone help me ???

Link to post
Share on other sites

Had to create an ID on this forum just to say thank you.  Got the dreaded software error screen on our AppRadio4 after I met up with my wife to swap cars. Of course, this was 3 hours from home and she was supposed to take the car with the CarPlay unit.  Because of this forum I was able to download the image to a USB drive, swap out the SD Card in the radio, install the image, and update it to the latest firmware, all while she was still working lol!

Nice thing is it is a little faster with a better SD Card in it too.

So, thank you to everyone who contributed to this thread!

Link to post
Share on other sites

Hi Guys I have a problem with my bluetooth in my avic F70DAB.
When I enter the bluetooth menu the is only the error msg 'ERROR-2'

Ive tried already to upgrade the whole software to 1.10 but nothing changed.

Then I tried to use the testmode to restore all data to factory , but the 1.10 software doesnt allowed me to get acces.

Then I downgraded the software to 1.05 , I was able to get into the testmode and made a readout of the error logs.

I deleted all logs and restoed the device to factory setttings.

The error is still there .
Please help out .



Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...
On 2/18/2018 at 6:16 PM, mikes1971 said:

I just purchased a used Avic-8000nex. All workes fine. I'm thinking I should back up the internal SD card just to be safe. Is it as easy as just removing the top or bottom cover to access the card then just copy the contents of the card into a folder on my PC? 

Good idea, however the SD card is locked so it will not show up in Windows/any computer. There is a process for unlocking the card, which is done on the head unit itself. I've never done it but there is info online or on this forum somewhere to unlock the card and then grab the image file. 


The actual process for opening up the head unit isn't too difficult, just got to be careful and remember where the screws go.

Link to post
Share on other sites
  • 2 months later...
  • 4 months later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...