Jump to content
AVIC411.com
kellinaradway

2015 Avic Z120 map update

Recommended Posts

IIRC there have been similar problems reported here with the Galaxy S5 after upgrading. I think it started with the 2013 version (which is the same BT files as 2015). So maybe there was some incompatibility between the S5 software and last Pioneer (Parrot) BT. You might look for those threads. I think some people fell back to the older BT software - I forgot what version. If you can find the older files you can install them the same way through the BT settings menu.

 

I was having some BT audio connection problems after the 2013 update. I have a Nexus 5. But it cleared up after newer releases of Android. I'm on v6.xx now and my only BT problem is re-connecting to a BT source when I start the car. It seems to timeout waiting for the phone connection. It doesn't happen every time.  I just need to wait for the phone to reconnect then toggle to a non-BY source and back.

 

Another option (if you feel comfortable hacking your phone) is to install a custom Android ROM on your phone. The xda site (link) has several S5 ported Android v6.xx ROMs with many customizations and features. Now guaranty but that may solve your problem.

So..How about a way easier method. Pioneer on the phone told me (a blatant lie) that it was impossible to revert the bt fw back to 3.24.

I just found a post on here titled "z140bh Bluetooth audio problem". There's a link to download a 2.3 gig file containing the 2012 software including the the bt fw 3.24. It worked I just did it and now i am so relieved that i don't have to go out and spend $1k plus for a new HU. Not having something work drives me insane. I guess I'm ocd that way. I have the need to fix things and make things work lol...That post has great instructions. Super easy. Get this info out there...and the name of the file is cnsd-310fm

 

My pandora is controlled from the HU and plays through my truck speakers again. 

Share this post


Link to post
Share on other sites

So..How about a way easier method. Pioneer on the phone told me (a blatant lie) that it was impossible to revert the bt fw back to 3.24.

I just found a post on here titled "z140bh Bluetooth audio problem". There's a link to download a 2.3 gig file containing the 2012 software including the the bt fw 3.24. It worked I just did it and now i am so relieved that i don't have to go out and spend $1k plus for a new HU. Not having something work drives me insane. I guess I'm ocd that way. I have the need to fix things and make things work lol...That post has great instructions. Super easy. Get this info out there...and the name of the file is cnsd-310fm

 

My pandora is controlled from the HU and plays through my truck speakers again. 

Great news. I am assuming you just updated the BT using CNSD-310FM's v3.24. and are still running 2015 maps?  BTW, I'm sure that the out-sourced 1st tier tech support is just reading from a script. They don't know jack and if your problem isn't trivial they are no help.

Share this post


Link to post
Share on other sites

Great news. I am assuming you just updated the BT using CNSD-310FM's v3.24. and are still running 2015 maps?  BTW, I'm sure that the out-sourced 1st tier tech support is just reading from a script. They don't know jack and if your problem isn't trivial they are no help.

Yes still running the 2015 maps with no other problems to report. 

Share this post


Link to post
Share on other sites

Thank you for all the time and effort everyone has put into this.  RonS, kellinaradway and BlakeStone have gone above and beyond.

 

I haven't been able to update my x930bt to the 2015 maps yet because the links time out for me but I'll keep trying.  I've been trying for 2 days now but the download usually stops at ~160MB.  I've been up to ~250 MB on a couple of occasions but the download just stops and says it is complete.

Share this post


Link to post
Share on other sites

Great news. I am assuming you just updated the BT using CNSD-310FM's v3.24. and are still running 2015 maps?  BTW, I'm sure that the out-sourced 1st tier tech support is just reading from a script. They don't know jack and if your problem isn't trivial they are no help.

 

Will this work for x940bt unit??

Share this post


Link to post
Share on other sites

I have a Z150BH.

 

After thoroughly reading this topic, I am still a bit confused as to whether this will work with mine.

I have downloaded the Map file from #84, and the CARDInfo from #140.

 

Should I or shouldn't I test if this works?

Or do I run a chance of bricking my unit?

Share this post


Link to post
Share on other sites

I have a Z150BH.

 

After thoroughly reading this topic, I am still a bit confused as to whether this will work with mine.

I have downloaded the Map file from #84, and the CARDInfo from #140.

 

Should I or shouldn't I test if this works?

Or do I run a chance of bricking my unit?

The one in this thread won't work on a Z150. Take a look here 2016-maps-are-out-for-avic-x950bh-avic-x850bt-avic-x8510bt-avic-z150bh

Share this post


Link to post
Share on other sites

The one in this thread won't work on a Z150. Take a look here 2016-maps-are-out-for-avic-x950bh-avic-x850bt-avic-x8510bt-avic-z150bh

RonS (or anyone who knows),

 

My understanding, please correct me if you think/know I'm wrong, is that the data files can be updated but the system files (a.k.a. the firmware) cannot* because the processor is different between the two units.  I do not know** if the data files are different or dependent on the firmware but am really curious to know.  Any insight greatly appreciated.  Thanks.

 

Reference (this is an old video and not directly related to these units but is the fruit of my understanding):

 

* Without major work. :)

** I may try this myself to know but am being lazy now.

Share this post


Link to post
Share on other sites

All this Z150, X950 (anything ending in 50) stuff is off topic for this thread. It's cluttered-up enough. There are already a couple threads for these units. So please use those.

Bitmap, that video doesn't really mean much here since it refers to a much older model (x710) which runs totally different application (iGo). AFA the x50 units, I have no knowledge, but I would not assume that you could install just maps. Beyond that, I'll stay out of this effort. Good luck.

Share this post


Link to post
Share on other sites

Here is the nag screen hack for this release (v6.0)

 

Apply this binary patch to /USER/PRGn*/APL/NAVI.EXE 

 

at offset 0xBEC64  

change 05 00 00 0A   to   00 00 A0 E1

 

*See below for the correct path to the file for your unit.

 

Note: do not install the upgrade with the edited file on the SD. If you do, the installation will fail. After it is successfully installed, you can use a copy of the one on the SD (in UPDATE\USER\PRG\APL) to patch, then use a separate SD with testmode.key and the patched NAVI.EXE on it to update your unit. I recommend not modifying the file on your installation SD.

 

This is dangerous - especially for noobies. Make a backup of any files you change - in fact making a backup of all files under \USER is a good idea.

 

* there are two \USER\PRG directories on your HU. The active one is indicated by the presence or absence of a file named \USER\PRG.FLG

If this file is not present, the active files are in \USER\PRG0\APL. Otherwise, the active files are in \USER\PRG1\APL

 

I Rons,

 

i tried to find the offset on my Navi.exe file (F940BT) freshly updated with 2015 files, but this offset doesn' exist.

 

Any idea on pointing me how to remove the nag message?

 

in fact will write a bigger post as i got several issues on this unit as

1) i cannot enter the seting (greied) = brake green cable is grounded and the mute wire relocation doesn't work

2) I do not know where to copy my speedcam file in this damned unit !

 

Anyway on thing at a time.

 

Thanks a lot for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×