Jump to content

F9220BT Lost Bluetooth Firmware

Recommended Posts

Hi guys and gals,


I too have the missing BT-firmware problem ever since I bought the car second hand.

I updated my unit (F920BT!!) from the 2010 to the 2015 maps version and then tried to update my bluetooth firmware aswell.

It showed a message that the update would take several minutes etc. but after a few minutes gave up:
"an error occured and the BT firmware could not be updated".


Could it be that it can not update because there is no original firmware to be found ("Version: ----------- ") ?

If so

1 were do I get my hands on the original 2010 version of that file?

2 what file am I looking for?


Any suggestions are welcome as I am running out of ideas here.

Share this post

Link to post
Share on other sites

I have exactly the same problem. I managed to update the BT firmware via the supertestmode but it did not solve the issue for me. It seems that some settings in the application software are messed up. It might have to do with the file in \SETUP\BT\BTUNIT.DAT . Can anyone provide a copy of this file from a working unit?

Anyway, if someone wants to try to update the BT firmware via supertestmode, just put the 3 files that are contained in the latest map update in \FIRMWARE\BT on an SD-card in the folder \AVICZ110\BLUETOOTH and select update bluetooth firmware from the "forced firmware write" submenu in the supertestmode. Use the paths exactly as given even if you don't have an avic Z110.

You can also check if your BT module is working from the testmode. Just go into the "Tel test" submenu. here you can open and init the connection to the module and pair with your phone. Once paired you can dial a phone number from this menu. My BT module works fine this way. Also the BT firmware update was successful, but in the settings BT is still greyed-out. So it definitely must be a problem of the Pioneer application SW and not of the Parrot bluetooth firmware.

Share this post

Link to post
Share on other sites

Did anyone ever fixed the issue? My bluetooth stopped working out of nowhere. I had my car on accessory, and when i turned my car fully on, the bluetooth didnt connect ever again. I go to settings and see its grayed out and says visibility is off and wont allow me to turn on, also get error-02 on the screen

Share this post

Link to post
Share on other sites

Hi all,

still mourning the disactivated BT-funtions of my unit.

Did anyone make any progress?

Still no lead on the update-files that might jolt the thin back to life with an update attempt.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now