Jump to content


Photo

Appradio sphda120 Europe with US v1.09 firmware


  • Please log in to reply
18 replies to this topic

#1 bravo2zero

bravo2zero

    Member

  • Members
  • 35 posts

Posted 23 October 2015 - 10:27 PM

Well a few weeks back I posted on here will it work if I popped the latest American on a British head unit , I got answers like " don't it will brick your radio ".

I was looking around loads of forums and Facebook groups and nobody seemed to want to do it or answer my question so I just did it.

Well here's the lowdown for anyone thinking of doing it ...... Do it !

I did it !

I followed the regular instruction and it updated and restarted back up no issues ans sporting the 1.09 firmware.

There is zero .... Nothing ... Zilch different to layout or apps , I don't have any US only apps like Pandora included just the stuff I had on with v1.07. All my functions work fine for CarPlay but more stable and vastly quicker. I click on apps in CarPlay and they open before I have chance to remove my finger off the screen , where as before there was 6-10 second delay.

I've used the radio about 11 hours since updated and so far the bugs in 1.07 I was experiencing have gone , soundless playback , pressing skip caused radio to go quiet till you pressed pause and then resumed and the sound went back normal, random crashing back to pioneer screen and rebooting.

I an using iPhone 6 Plus iOS 9.1

To summarise

No bricked radio as I was told
Vast speed improvement
Bugs for me personally have been fixed

#2 cage911

cage911
  • Members
  • 2 posts

Posted 24 October 2015 - 12:08 PM

Great news

#3 Peeweebck

Peeweebck
  • Members
  • 9 posts

Posted 25 October 2015 - 03:07 PM

I may do this to mine as I have the Europe firmware for my iPhone 6 and I will connect the first time in the car but after that I just won't connect to phone at all for using music . The Bluetooth is fine but the apps are a pain in the ass

#4 hilux_hx

hilux_hx
  • Members
  • 17 posts

Posted 26 October 2015 - 09:11 AM

Great! I will try the 1.09 firmware on my European unit today. Hope there will be some Mirrorlink and Android improvements.



#5 fruitbat04

fruitbat04

    Member

  • Members
  • 48 posts

Posted 26 October 2015 - 07:25 PM

I took the plunge and all seems well. It does feel slightly quicker but that could be a trick of the mind!

#6 400ixl

400ixl

    Member

  • Members
  • 63 posts

Posted 31 October 2015 - 10:17 AM

Its been done all the time right from the AppRadio 2 onwards, so surprised you didn't find loads of info. Mind you it has been more by the Android people who go the opposite way in getting rid of the restrictive US firmware, for the EU one. This means you don't need a handbrake bypass for full screen mirroring which is much more common with Android users.

 

So, if you just use the basic, restrictive Pioneer features then worth looking at.

 

However, if you have freed up your experience with the likes of AppRadio Unchained on Android, then be warned you will then need a handbrake bypass device if you go from EU to US firmware.



#7 hilux_hx

hilux_hx
  • Members
  • 17 posts

Posted 02 November 2015 - 11:49 AM

I have done the update from 1.08 to 1.09 on my EU unit. Works great, but no new features. The US related stuff (Pandora, ...) is not visible. Just like before. That means the US and EU headunits use the same firmware. There have to be some differences in the hardware (solder jumpers, resistors, config eprom or something else) so the firmware can check if it's an EU or US unit.

@400ixl: Even there is no need for an parking brake bypass circuit. Just grounding the parking brake wire seems to work well.

Hoping for an update to get Android Auto!



#8 fruitbat04

fruitbat04

    Member

  • Members
  • 48 posts

Posted 09 November 2015 - 05:25 PM

I agree with the above. I didn't lose my parking brake wire bypass upgrading either. They will likely be a hardware mod or the USA people would just be doing the EU upgrade to get a proper bypass.



#9 hilux_hx

hilux_hx
  • Members
  • 17 posts

Posted 17 December 2015 - 10:15 AM

New firmware 1.11 for AppRadio 4 SPH-DA120! Will try it today on my European Unit (now has 1.09).



#10 hilux_hx

hilux_hx
  • Members
  • 17 posts

Posted 17 December 2015 - 02:31 PM

Done. Still fully works with firmware 1.11 on my European unit. Just the bluetooth firmware is 3.21.3 like before. Do the US units have a newer one? A manual update didn't changed this.



#11 DeViaNCe_44

DeViaNCe_44
  • Members
  • 2 posts

Posted 22 December 2015 - 08:34 PM

Hi guys !

Did someone have the same issue as i do, when i try to update from 1.08 EU to 1.11 US (or even 1.09 US) it says "No device, try again later" ? I am following the instructions step by step, with the AVIC5000NEX folder at the usb root, so i don't get why it gives me this message.... Any help please :)



#12 DeViaNCe_44

DeViaNCe_44
  • Members
  • 2 posts

Posted 22 December 2015 - 09:46 PM

I solved my problem ! If anyone is experiencing the same issue, I tried to update with several usb keys, a 2go Noname, 16go Sandisk, and finally the 4go Verbatim worked for me ;)

#13 fruitbat04

fruitbat04

    Member

  • Members
  • 48 posts

Posted 28 December 2015 - 06:15 PM

Worked again for me as well. Bluetooth firmware as well

#14 fruitbat04

fruitbat04

    Member

  • Members
  • 48 posts

Posted 29 December 2015 - 09:59 AM

Actually although it said the BT firmware was successful, after reading this post

 

http://avic411.com/i...em/#entry337472

 

I checked and it's the same for me. I don't think it actually updated it.



#15 mrfish1968

mrfish1968
  • Members
  • 1 posts

Posted 02 March 2016 - 06:25 AM

Well it kind of works on my da120. Now The CarPlay screen looks like it is not centred and is off by half a screen to the left, and half a screen to the top. This means I can't see anything properly and only see a tiny portion of CarPlay screen.

Anyone had this?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users