Jump to content
AVIC411.com
Bear Down

GPS takes a long time to display.

Recommended Posts

My gps takes 15-20 seconds to start displaying the map. I'll get the spinning wheel for a while before the maps appear. Sometimes I'll be almost out of my street before it displays. GPS connections show that I'm getting a good signal. Is this normal? My antenna is mounted in the center of my dash under a mesh speaker grill. I've taken off the grill to see if it helps but it's still the same.

Share this post


Link to post
Share on other sites

Yea, that seems about right, I wish it would load at start but it doesn't aways....  You'd think that all the 'standard' features would start at the beginning.... The HD Radio is available as the splash screen is showing... 

Share this post


Link to post
Share on other sites

Two years later, and this appears to be the same situation. I came to the forum seeking answers on my newly-installed 8200 only to see this disappointing thread. I'm glad you posted the question Bear Down. I was prepared to replace my retained OEM GPS antenna thinking that might be the culprit.

Share this post


Link to post
Share on other sites

This unit is far slower than a (audibly crappy) Kenwood Epsilon, their best.  Any system must have current geo-synch data from GPS satellites, so they're asleep, the more time required.  Our problematic BMW 7er was quick to boot, as the system left the GPS 'hot' for some time, keeping data-current, then allowed it to doze off.

Kw had a faster CPU, quickening boot time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×