Jump to content
Sign in to follow this  

NaviExtras Does Not Recognize USB Drive

Recommended Posts

I am trying to update my maps and cannot get toolbox to recognize the drive. I have updated them before 3 years ago, so I am familiar with the procedure, it's just not working this time. I've been exchanging emails with customer support but no success yet. I have an AVIC7000NEX. Here are the steps I've taken....


The synctool works just fine, I'll insert a blank USB drive that's been formatted to FAT32 into my unit and it successfully places a "synctool" folder on the drive. When placing this drive into my computer, toolbox does not recognize it, but the computer does. 


I've uninstalled and reinstalled toolbox. I have tried the same steps on three different computers, two running Windows 7, one Windows 10. I know the drive needs to be at least 8GB, but for the hell of it I've tried 4GB, 16GB, and 32GB. I even tried a micro SD card with a USB adapter that was 8GB. 


Last email they wanted me to send the log file (again) from toolbox. I sent them two, one from a Win 7 computer and the other form Win 10. 


Any ideas? 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this