Jump to content
AVIC411.com

2017 v7 US/Can Update available for Z110/120/130/140,X920/930/940


Recommended Posts

  • 1 month later...
  • Replies 212
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 2 weeks later...

Hi guys,

I have a bone stock X920BT, no map or firmware updates since I bought it.

I have downloaded and run the ShortFuse Hack, and downloaded the Z110Z120X920CARDINFO.zip.

Can anyone re-link the 2017 update? I'd be willing to donate for your time and effort. Like zoom says, the google drive link is empty.

If no one has the update anymore, does anyone have experience dealing with avicfix?

https://www.avicfix.com/2017-map-upgrade-pioneer-avic-x920bt-z110bt-z120bt/

Thanks all for putting out all this out there.

Link to post
Share on other sites
  • 2 weeks later...

Blake, Smoke, Ron, netz, everyone...thanks! The instructions in this forum were simple and clear. This latest link worked like a champ. Did the install today, upgraded from factory original to v7.0 and BT v3.32. Still didn't fix my bluetooth connection which has never worked for android; now my phone tells me 'incorrect password' instead of just 'can not pair'. I'll keep working on that.

Recap: 8gb micro sd; FAT32 format; load and run shortfuse hack; get correct cardinfo file for x920bt; download link above; replace hack on sd card with cardinfo file, firmware folder, and update folder; run update [password = passwordpassword]; update firmware in bluetooth in settings; eject sd card; enjoy updated unit.

Just a note - Blake's link worked great. smokingman's link gave me a 23 hour estimated download.

Link to post
Share on other sites
  • 1 month later...

Just completed the update tonight for the map and it worked flawlessly. However, when I updated the BT firmware, the unit no longer shows my iPhone connected in Bluetooth Audio mode but the phone is showing paired with the unit in the BT menu. Do revert the BT firmware version back to the pre 3.32 version or try something else?

Link to post
Share on other sites
7 hours ago, Kdogg said:

...the unit no longer shows my iPhone connected in Bluetooth Audio mode but the phone is showing paired with the unit in the BT menu. Do revert the BT firmware version back to the pre 3.32 version or try something else?

You might try re-pairing the BT connection first.  Sometimes it is necessary to do a hard restart  after a bluetooth  upgrade. Simple  surefire way is to  disconnect the battery for 30 seconds. Or, if you know  both fuses that power the radio,  you can just  pull them. 

If that doesn't fix it then try older  BT firmware.  maybe even re-installing 3.32.

Link to post
Share on other sites
6 hours ago, RonS said:

You might try re-pairing the BT connection first.  Sometimes it is necessary to do a hard restart  after a bluetooth  upgrade. Simple  surefire way is to  disconnect the battery for 30 seconds. Or, if you know  both fuses that power the radio,  you can just  pull them. 

If that doesn't fix it then try older  BT firmware.  maybe even re-installing 3.32.

I will try disconnecting the battery tonight. Thanks for the response!

Link to post
Share on other sites
  • 5 months later...
  • 1 year later...
On 8/28/2019 at 11:26 AM, crai6m4ck1 said:

 

 

A quick recap for those coming here in the future to upgrade their head unit to version 7 firmware, 2017 maps, and the latest Bluetooth version.  A special thanks to RonS for his help! 

 

Quoted from an earlier post of his, “This is a hack to prepare your unit to install a map/firmware update. Confirmed to allow firmware updates for all Z110, Z120, Z130, Z140, X920, X930, X940 - and probably their corresponding rest-of-the-world units. I can't say whether it will work with the very old units, and it won't work with the model numbers ending in 50 or greater,  or Nex units. 

 

This should work with the following F series models:

F10BT, F20BT, F30BT, F40BT, F840BT, F8430BT, F920BT, F930BT, F940BT, F9210BT, F9220BT, F9310BT”

 

This is the process that worked successfully with my x930bt and I would assume should work with all the models listed above (though I make no guarantees).


 

First

Download the ShortFuseScript.zip from here:

http://avic411.com/applications/core/interface/file/attachment.php?id=16863 22.66 kB · 1527 downloads

Extract the files (Hacked.dll, ScriptExec.ini, and TESTMORE.KEY) and place them in the root of an SD card.  

Insert the SD, it will prompt you to press any key (button) to continue - or - turn off the ignition to abort.  Press a button and it should finish fairly quickly.

 

Next

Install the version 7 firmware and 2017 maps found here

Pioneer_T1000-25818.zip 

https://drive.google.com/open?id=0B5KpUvEq0nCnb29SZFVlNTZrZUk

You’ll be prompted for a password to open the encrypted file 

Password: avic411s

Extract the files out of the Pioneer folder and put them on the root of an SD card

Insert the SD card into the head unit and when prompted for the password enter: PASSWORDPASSWORD.  

It should take up to 30 minutes to install

 

Lastly, go into Bluetooth settings and select upgrade firmware.  

 

You’re done!

 

This is a really simple way to upgrade your unit that anyone should be able to handle.  Just make sure that you keep the power on at all times. I even left my vehicle idling just to be safe.  

 

For those not technically inclined, the Root of SD card means that the files are at the very top level and not within other folders.  So when you open the SD card you immediately see the files and you don’t have to explore folders to find them.

 

Good luck!

Hello crai6m4ck1

Thanks for this recap,  when installing ShortFuseScript AND the firmware update, do we need 2 SD cards or will it work if we put all the files on one card?

 

Link to post
Share on other sites
20 hours ago, DBock said:

Hello crai6m4ck1

Thanks for this recap,  when installing ShortFuseScript AND the firmware update, do we need 2 SD cards or will it work if we put all the files on one card?

 

To be safe, don't put them on the same card at the same time. You don't need two SDs. You can install ShortFuse then format and re-use the same card for the map update.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...



×
×
  • Create New...